5

Alright. This is the scenery that I got:

1) I am using Ubuntu 14.04 LTS

2) I am using an american (international) keyboard

3) OS is in the following language: Portuguese Brazil (brazilian portuguese)

4) I am a new user of Linux. I am almost 30 years old and I have been using Windows for my WHOLE life, so I don't know NOTHING about how to configure or set Linux/Ubuntu.

5) I've JUST installed this OS for the first in my notebook.

6) Every letter that I try to write with an accent comes like in the examples above:

  • 'a (when the correct should be á)
  • 'c (when the correct should be ç)
  • ~a (when the correct should be ã)
  • ^o (when the correct should be ô)

    Could please someone tell me how do I fix this?

Thank you all!

5

(I do not know Brazilian portuguese.) The name of the feature you are trying to use is "dead keys". A dead key is chosen so that it has a label which is similar to an accent and when it pressed it does not create a new letter, you have to press a second key too. Some combination results in the accented version of the second letter.

There are more than one builtin keyboard layouts in Ubuntu even for a single language. As I see there are five for your language:

  1. Portuguese (Brazil)
  2. Portuguese (Brazil, Dvorak)
  3. Portuguese (Brazil, eliminate dead keys)
  4. Portuguese (Brazil, Nativo)
  5. Portuguese (Brazil, Nativo for US keyboards)

You have to choose either of 1, 4, 5. You can also choose the US international layout with dead keys, which seems to be popular among Brazilians:

  1. English (US, international with dead keys)

You can add a new layout by

  1. clicking on the input source (keyboard language layout) switcher near the right end of the panel to show the popup menu
  2. selecting Text Entry Settings from the menu
  3. Pressing the plus button below the Input sources to use list.

By the way, there is a keyboard icon on the right of the plus button which displays the chosen layout.

If you have more than one keyboard layout in your Input sources to use list, then you can switch them by either clicking on the input source icon on the profile or pressing Super + Space.

For example, if I select Portuguese (Brazil) I can type the letter á by pressing the English keys [a in sequence.

As usual, each of the things I mentioned above can be customized.

|improve this answer|||||
  • I don't think your reply is correct. 'Portuguese (Brazil)', 'Portuguese (Brazil, Dvorak)', 'Portuguese (Brazil, eliminate dead keys)', 'Portuguese (Brazil, Nativo)' and 'Portuguese (Brazil, Nativo for US keyboards)' are all types of different keyboards (in other words, I mean that each of these options actually changes the keys "arrangement"). They are not "keyboard settings". And as I said my keyboard is AMERICAN (my notebook was bought in USA), which means that my keyboard is none of these types that you said. – Jorge Bill Feb 15 '15 at 11:53
  • I do not know what keyboard layout you are usually using in Brazil or what kind of layout you want to use personally. I assumed that you want a Brazil layout. Note that the hardware of the keyboards are always the same, for example a 102 key US English keyboard is the exact same hardware as a 102 key Hungarian keyboard, they only differ in the labels printed on keycaps. The translation from keypress to letter is done by the OS. One thing is sure though, you need to select a layout which has dead keys enabled. – Hontvári Levente Feb 15 '15 at 12:12
  • After reading the issue tracker page linked by Gunnar Hjalmarsson, I understand that some Brazilians use the US International layout with dead keys. I tested it, and indeed it works for me, except for ç. To select this layout, use the procedure I wrote above, but instead of the Brazil variants, select English (US, international with dead keys). Regarding ç, see the issue report. – Hontvári Levente Feb 15 '15 at 12:22
  • Excelent. This worked for me! So Brazilians who have american keyboards should set 'English (US, international with dead keys)' so letters could be writen with accents (á, é, ú, ç, ô, ã). – Jorge Bill Feb 15 '15 at 12:35
  • I am glad that we could sort it out. I updated my answer with this layout. – Hontvári Levente Feb 15 '15 at 16:32
-1

I had the same problem. Solved it reinstalling ibus:

sudo apt install --reinstall ibus

You may need to do a full purge and then reinstall:

sudo apt purge ibus && sudo apt install ibus 
|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.