31

By default, the transition from one virtual desktop to another one under GNOME2 in Ubuntu 11.04 is visualized with a sliding animation. How can I turn that animation off?

3
  • Haven't got a full answer; you need to install Compiz settings manager, the settings will be in the desktop category
    – danjjl
    Aug 25, 2011 at 8:59
  • @danjjl Thanks - if you make that a real answer, I'll tick it off as correct. Please add that in CCSM, the setting is under Desktop/Desktop Wall/Viewport switching/Wall sliding duration.
    – Thomas
    Aug 25, 2011 at 9:31
  • Just in case you are wondering: The package name is compizconfig-settings-manager and you can invoke it from your console by typing ccsm. Nov 24, 2016 at 12:37

4 Answers 4

45

To change the animation you will need CompizConfig settings manager

To install it:

apt-get install compizconfig-settings-manager

or via Ubuntu Software Center.

Open CompizConfig settings manager.

Under DesktopDesktop WallViewport switching set Wall sliding duration to 0.

6
  • Can this be applied to Ubuntu 14.04?
    – RNA
    Nov 26, 2014 at 6:57
  • @RNA Still available in Ubuntu 15.04, so I assume it's also in 14.04 May 22, 2015 at 17:17
  • 2
    Works as well in Ubuntu 16.04.1 with Unity 7.4.0. Sep 13, 2016 at 18:08
  • 1
    does not work with Ubuntu 18 Oct 14, 2018 at 16:13
  • 2
    @FabrizioBertoglio Since Ubuntu 18.04, ubuntu switched from a compiz based window manager to mutter. This answer will only work with compiz as a window manager
    – danjjl
    Jul 2, 2019 at 9:34
3

for Ubuntu 18.04 I use this, you just need to install the gnome-shell extension (for either chrome, firefox) and then

https://extensions.gnome.org/extension/1328/disable-workspace-switch-animation/

0
1

If it is reasonable to turn off all Gnome animations, the following works on Ubuntu 21.10:

Install Gnome Tweaks: https://wiki.gnome.org/Apps/Tweaks (edit: search for and install "Tweaks" in the "Ubuntu Software" app, OR install the "gnome-tweaks" package using the APT command line.)

General > Animations > (turn off the switch)

1
  • 2
    In Ubuntu 18 it's a toggle under Appearance. Dec 16, 2021 at 13:58
0

Applications -> Appearance -> Behaviour -> Set Visual Effects to Low

enter image description here

On a Side note: Eventually, I ended up reverting back to animations, because the sudden switch from my dark code screen to something to light backgrounds like browsers was too much for my eyes.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.