1

I have 2 nVidia GeForce GTS 450/PCIe/SSE2 graphics cards, each with a DVI, VGA and HDMI port.

Unfortunately, only one of these cards is detected by Ubuntu, so I have to have one screen on VGA and the other on DVI. I'd like both to be DVI.

I am using Ubuntu 14.04 GNOME, fully updated. It never worked with 12.04 unity or 14.04 unity.

I am happy to edit in any information (but I have no idea what is needed right now).

3
  • Hi Tim! :-) What version of the NVidia drivers are you using? Do you have CUDA installed? (drop by in the chat room next time) :P – Fabby Feb 17 '15 at 10:00
  • The latest, 331-updates. I don't think it has ever worked - even with other drivers. – Tim Feb 17 '15 at 10:01
  • AskUbuntu general room? – Fabby Feb 17 '15 at 10:02
1

Source, Unix & Linux

I finally got this working, 2 Graphics Cards (nVidia GTS 450) with both screens on DVI.

Here is my xorg.conf:

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"

    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Acer S220HQL"
    HorizSync       31.0 - 82.0
    VertRefresh     56.0 - 76.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 450 GTS"
    BusID          "PCI:1:0:0"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "CRT-0"
    Option         "metamodes" "GPU-56281125-01c7-ee85-b8b9-b3e5cf94b7c5.GPU-0.DVI-I-0: nvidia-auto-select +0+180, GPU-cbc59e3f-e8c1-a347-a069-b62f6b885f7d.GPU-1.DVI-I-0: nvidia-auto-select +3600+0 {rotation=right}, GPU-cbc59e3f-e8c1-a347-a069-b62f6b885f7d.GPU-1.DVI-I-3: nvidia-auto-select +1680+180"
    Option         "MultiGPU" "Off"
    Option         "SLI" "off"
    Option         "BaseMosaic" "on"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Note that it only references 1 GPU, so it doesn't need another X Screen.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.