7

When I connect my Android phone to my Ubuntu 14.10 computer (Gnome Flashback), it connects without errors, and a Nautilus window opens:

Phone in Nautilus

I went into Phone/Music directory, and I wanted to create a new folder named Playlists, because I'm trying to get Banshee to sync music, and I read that having a folder called Playlists might help. Nautilus let me create a folder called Untitled Folder, but then when I tried to rename it to Playlists, I got this error:

libmtp error

The item could not be renamed. Sorry, could not rename "Untitled Folder" to "Playlists": libmtp error: could not set object property list.

How do I get flawless MTP connectivity to my phone from Ubuntu?

  • Maybe you need to add yourself to the group of users that can rename the playlist? Perhaps your current user has different permissions than the ones needed. – Muaad ElSharif Nov 15 '16 at 19:00
  • I think my answer should fix the problem. – user595510 Nov 21 '16 at 17:04
  • @MarkYisri I wish it had... – Elder Geek Nov 22 '16 at 16:56
3

You are using v1.1.6 of libmtp which is not the very latest; in Vivid version 1.1.8 is available.

You could try a new version of libmtp to see if this resolves your issue (it could be a bug in that particular versioin) - one such source is my PPA:

sudo add-apt-repository ppa:fossfreedom/libmtp
sudo apt-get update
sudo apt-get upgrade

If this doesnt work for you, rollback using ppa-purge

sudo ppa-purge ppa:fossfreedom/libmtp
  • 1
    I realize this post is over a year old, but renaming via mtp is still a pain (doesn't work for me on 14.04 nor 16.04) I tried your PPA but that didn't work for me. I ended up using a USB sdcard reader to rename files. If there's a better way I'd love to hear about it. – Elder Geek Nov 15 '16 at 18:52
  • @ElderGeek I'm not too familiar with Media Transport Protocol (MTP) but I did a quick test with my Android 6 phone and double clicked on SD RAM storage. Then using Nautilus I created a folder called ElderGeek then renamed it to ElderGeek2 with no problems. I haven't installed any special software in Ubuntu and don't recall doing anything special to the phone's software... I just plug it in and it's visible to Nautilus. – WinEunuuchs2Unix Nov 20 '16 at 2:53
  • @ElderGeek my answer should work – user595510 Nov 20 '16 at 15:14
2
+50

This answer should help you:

sudo apt-get install mtpfs

Once that's installed, plug in the phone to your computer. If nothing happens, on the phone go to Settings > Storage > Upper Right Corner () > USB Computer Connection > Media Device.

edit:

Settings > Search (type in "usb") > USB configuration ... If non existent make sure developer options have been enabled.

Open Settings> About> Software Information> More.
Then tap “Build number” seven times to enable Developer options. ...
Go back to Settings menu and now you'll be able to see “Developer options” there.
Tap it and turn on USB Debugging from the menu on the next screen.

Once they have been enable and the above package installed, also be sure to have the phone plugged in and then go back into developer options and update the USB configuration as shown in the picture below.

enter image description here

  • I've been attempting to change a contact file extension from .vcard to .vcf so that I can import it into my contacts easily. I still get the libmtp error could not set object property list. I'm not having a problem connecting via mtp as libmtp is installed properly. I get the same error whether mtpfs is installed or not. normal user or super user access or not. No change. – Elder Geek Nov 21 '16 at 13:47
  • @ElderGeek what Android version is this? – user595510 Nov 21 '16 at 16:20
  • Android version is 4.2.2 – Elder Geek Nov 21 '16 at 17:29
  • I'm awarding you the bounty for the attempt. – Elder Geek Nov 23 '16 at 14:16
  • @ElderGeek thanks so much! If I have any other information, I'll be sure to put it up here. – user595510 Nov 23 '16 at 14:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.