After using my new Ubuntu for the first few months without looking for problems, I'm starting to try and tweak some things that would make my life easier.

Running Ubuntu 14.04, when I switch to Hebrew - which was set as the second language when I bought the computer - all the regular hot keys such as ctrl-z, ctrl-c, ctrl-v stop working and I have to switch to En do what I need to do, then switch back to He and continue working. It's getting annoying.

I don't really understand why is it that shift+alt works to switch back to En, and the rest don't.

Does anyone have a fix? is this something unique to Hebrew, or does it also happen with other languages?

Please let me know if I need to post any additional system info to get the ball rolling. TIA

Edit - First of all, I edited the title - I either just noticed that it happens only in libreoffice, or it was like this all along. not sure. I changed one thing - in the text entry setting, I selected "allow different sources for each window".

I finally found my problem mentioned in another thread: LibreOffice can't use keyboard shortcuts while typing in any language but English?

One user there wrote that the problem was supposed to be fixed by updating to libreoffice 4.2, but I'm running and it sounds like the same bug.

I solved it by following another answer in the above thread, removing the libreoffice-gtk package, but just like a comment there warned, my libreoffice now looks like ms office from windows 95. I tried installing libreoffice-gtk3, but it doesn't change anything

  • Could you not just toggle to Hebrew and re-create all shortcuts there with the respective keys? – Byte Commander Feb 14 '15 at 14:26
  • I wasn't even thinking about that as an option, I just assumed the shortcuts are common for both input languages and are just not working. So you add shortcuts for every language separately? – joeav Feb 14 '15 at 14:40
  • I don't know, it was just an idea based on your description of the problem. If nobody else comes up with a better solution, I would try this as a workaround. But I think there must be another (maybe better) solution... – Byte Commander Feb 14 '15 at 15:13
  • See my edit - I will need the commands for the shortcuts I want to use if I'm going to add them to the shortcut list. Do you know where I can get them? – joeav Feb 14 '15 at 15:50
  • 1
    @Fabby No, I got the laptop a few months ago with 14.04 LTS already installed, and the hebrew package. The problem has to be the same one from an older thread I mention in the edit, because the fix worked for me, with the sacrifice of libreoffice-gtk – joeav Feb 17 '15 at 13:17

I am delighted to report that B"H (=God be blessed) I stepped on the ultimate solution for that highly counter-productive bug!

Only change your desktop from unity to Cinnamon/KDE and you're done (tested on 16.04 LTS). changing the desktop means changing the GUI that ubuntu wears. install "synaptic package manager", then search and install the cinnamon-desktop package. then reboot, and in the login screen don't just type your password and hit enter, but notice a small ubuntu logo that apears near the password field. click it, choose the cinnamon desktop. login. start libreoffice and type something in hebrew. click ctrl+z and see it disapear. praise your lord and give some charity for gratification!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.