0

After installation of 14.10 and the "automatic upgrade" of the kernel to 3.16.0-30-generic from 3.16.0-23-generic I cannot use my keyboard to enter my passphrase for decrypting my physical drive.

Any keyboard input is displayed at the first row of the 'ubuntu-decrypt-drive' phase/page/graphical picture.

Actually, keyboard input isn't working at all, except the possibility to use ALT+Fn combination takes me to an empty blinkning marker without any input-possibilites.

If I try switching with the Alt+Fx combination I just get a blinking marker at the first row and the first column, and the same result there: It takes keyboard input but I'm definitely not using the input to surpass my encrypted physical device.

When comparing the configuration files (config-kernel-generic) I cannot see anything that could cause this incident (side note: I'm not the best of both worlds regards to troubleshooting issues like this):

(sorry about the text-blob):

> diff config-3.16.0-30-generic config-3.16.0-23-generic

**3c3
< # Linux/x86_64 3.16.0-30-generic Kernel Configuration
---
> # Linux/x86_64 3.16.0-23-generic Kernel Configuration
68c68
< CONFIG_VERSION_SIGNATURE="Ubuntu 3.16.0-30.40-generic 3.16.7-ckt3"
---
> CONFIG_VERSION_SIGNATURE="Ubuntu 3.16.0-23.31-generic 3.16.4"
1934d1933
< CONFIG_GENWQE_PLATFORM_ERROR_RECOVERY=0
5049c5048
< # CONFIG_SOUND_OSS_CORE_PRECLAIM is not set
---
> CONFIG_SOUND_OSS_CORE_PRECLAIM=y*******

I used the guided "encrypt drive" during the installation of 14.10 and booting into the earlier kernel was and isn't a problem.

At this point I have to manually select my older kernel manually and can login/decrypt the drive without problems.

I am really thankful for any feedback or requests about further data since this is quite not what I've wanted and I've tried bypassing the incident by reinstalling ubuntu from scratch several times (suspecting there were a corruption/deficiency in the upgrade process) but I have no logs that points to that this is the cause.

Maybe my information has been lacking in regards to reporting my problem but I've been trying looking further into my issue and have noticed discrepancies in the initramfs in the kernel that works (3.16.0-23-generic) and the one which isn't (3.16.0-30-generic).

I ran a diff between the both lsinitramfs: http://pastebin.com/jLpLUk43

But I'm unsure in how to resolve the incident for the later kernel.

@user3807087 let me take my hat off and bow, cause this was driving me nuts and after numerous reinstallations and troubleshooting the incident I am now happy to say that your suggestion resolved the incident for me. (no need pressing the ESC though).

So to clarify the solution I edited the /etc/default/grub file and replaced the text in the row: GRUB_CMDLINE_LINUX_DEFAULT= to:

GRUB_CMDLINE_LINUX_DEFAULT="ro"

And then ran: update-grub

  • Thank you for helping me format the question correctly Sylvain Pineau. I actually added (Hello fellow Ubuntu users,) but when posted it was dismissed :D. Anyways, thanks! – fred-progress Feb 14 '15 at 12:54
0

Some possibilities: nomodeset lurking in the grub config http://ubuntuforums.org/showthread.php?t=2264430 Hit Esc in the prompt Ubuntu 14.10 boot takes ESC to give encryption passphrase prompt

I'm also seeking an answer, since I'm struggling with the same problem. Fresh install of 14.10, get the encryption prompt and nothing works.

I resolved this on my own machine just now, by removing the "quiet" and "splash" options from the kernel and using the same "ro" option used by the recovery mode. Otherwise, when running not in recovery mode, I get stuck at loading initramfs.

To do this, I edited /etc/default/grub to set the variable GRUB_CMDLINE_LINUX_DEFAULT to "ro" from "quiet splash"

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.