6

Ubuntu 14.04 LTS 64-bit: I used to get an icon for my portable drive on insertion. I have accidentally lost this by clicking on 'Unlock from Launcher' instead of 'Eject'. Now this icon does not appear when the drive is connected. How do I restore the original behaviour?

  • @Pilot6 WOW, I am impressed by the gesture. Thanks a lot. – Jacob Vlijm May 14 '16 at 19:19
  • You solved my problem with a perfectly written answer. I tried to recall where this setting was stored and immediately found this Q&A. – Pilot6 May 14 '16 at 19:23
8
+100

1. Command line:

You can do that by the command:

gsettings set com.canonical.Unity.Devices blacklist "[]"

Explanation

By removing the icon from the launcher, you blacklisted the device from the launcher. With the command above, you "empty" the blacklist.

If you want to to have a more selective way to set which device to keep in the launcher, first run:

gsettings get com.canonical.Unity.Devices blacklist

The output will be like:

['<device_1>', '<device_2>']

To restore device_1 in the launcher:

gsettings set com.canonical.Unity.Devices blacklist "['<device_2>']"

2. GUI

Alternatively, you can restore your icons with dconf-editor. You might have to install it first:

sudo apt-get install dconf-editor

(Or simply install it via Software-Center)

Then open the editor, browse to: com > canonical > unity > devices:

enter image description here

Then you can either set the blacklist to "default" settings (which is none), or remove devices from the blacklist selectively.

  • it worked. Sorry did not come here earlier to mark acceptance. – tagMacher Feb 21 '15 at 4:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.