1

I have been using Ubuntu 14.04 soon after it is released. Today I messed something up with the Chinese input ibus, and I don't know if this is the reason at all, but when I reboot using sudo shutdown -r now, I cannot pass the login. I entered the correct password, but then the screen just went black, and then the login screen comes up again!

I have searched quite a few solutions from others, but nothing is working for me.

I have read

I tried to look at .xsession-error, but that file is empty on my computer.

I tried the suggestion of changing the ownership of .Xauthority, but my .Xauthority is not root initially. I also tried to delete it but that does not work either.

I did sudo apt-get remove ibus-pinyin in case it is the problem (but not likely).

I also tried sudo apt-get install --reinstall lightdm, but it does not work either. I also tried dpkg-reconfigure lightdm, but I was not able to see the effect.

Also, I looked at /var/crash, and I saw a file _usr_bin_xpad.1000.crash, which seems to record the crash occured at the time that I first encountered thr login loop problem. Yet I cannot find further clue of how to solve it. At the bottom of that file, it suggested to update several packages if the crash still occurs. I did so but it does not work either. These packages are krb5-locales, libgssapi-krb5-2, libk5crypto3, libkrb5-3, libkrb5support0, libprocps3, procps

Can someone save me...I dont wanna switch back to Windows

  • Can you log into TTY1? You would have to press [Ctrl]+[Alt]+[F1] and manually enter your username and password into the terminal. – Byte Commander Feb 13 '15 at 19:55
  • Thanks for the attention. Yea certainly. If I cannot login to TTY, I cannot have tried those stuffs I listed. – zkytony Feb 13 '15 at 20:21
  • You could have done from within a live system... – Byte Commander Feb 13 '15 at 20:22
  • Okay..But do you have any idea how to resolve this? I will really appreciate – zkytony Feb 13 '15 at 20:27
  • Can you create a new user through TTY1 and then log into that graphically? – Byte Commander Feb 13 '15 at 20:29
-1

I solved a similar problem by erasing the file "/etc/shadow.lock". I tried this, because I had no chance to create new users... There is a second lock-file, named "passwd.lock". Only removing this file did not solve the problem.

Maybe this could work to escape from the guest-session loop. I will test this solution with other computers, when this error appears again.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.