2

My computer has been able to run Unity with no problems since I installed 11.04 a few months ago. The unity_support_test script have previously always given a firm yes to the question if Unity is supported. My graphics card is a NVIDIA GeForce GT 330M and I have installed the proprietary driver version 270.41.06.

However, Unity did not start today when I started my computer and logged in, instead I got the "Ubuntu classic" interface. I have restarted a few times and been extra careful to choose "Ubuntu" as session and not "Ubuntu classic" or any other non-Unity alternative, but the result is the same every time, Ubuntu classic and no Unity.

There were some updates yesterday, but I did not recognize anything interface related.

I have read some other questions and answers here, but I did not find anything useful. The only recommendation that I have followed was to install the CompizConfig Settings Manager and to check if the Ubuntu Unity Plugin was activated, but the plugin was already active as it should be.

As a final check before posting this question, I runned the unity_support_test script and to my surprise the answer was not "yes" but instead the following:

mghg@vaio-ubuntu:~$ /usr/lib/nux/unity_support_test -p
X Error of failed request:  BadWindow (invalid Window parameter)
  Major opcode of failed request:  138 (NV-GLX)
  Minor opcode of failed request:  4 ()
  Resource id in failed request:  0x1ff
  Serial number of failed request:  31
  Current serial number in output stream:  31

Please help me get back to Unity!

2

Reinstalling the drivers fixs the issue.

  • Thanks, reinstallation of the graphics driver indead solved the issue. However, for the first time when installing a graphics driver I got the following error message ERROR: File '/usr/lib/xorg/modules/extensions/libglx.so' is not a symbolic link. Why did this appear? – mghg Aug 25 '11 at 19:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.