1
 ffmpeg -i oceans.mov -an -c:v libx264 -r 24 -preset fast \
   -profile:v baseline -g 64 -keyint_min 64 -b:v:0 230k -maxrate 250k -s:v:0 304x128 \
   -x264opts pic-struct:no-scenecut -movflags frag_keyframe -f ismv oceans-250k.ismv

The error is:

At least one output file must be specified.

We have an mp4 file, we want to have separate bitrates for that file. When we used this command as specified in Creation of the Unified Streaming VOD pack, that's the error we get.

Thank you in advance.

  • Please show the complete console output from your command. – llogan Feb 13 '15 at 7:27
1

Try using the command without the backslashes (\), as these may be causing issues on the command line of your shell. The backslashes are used to denote command continuation onto another line, but if you are copying and pasting, then extra tabs and spaces can get picked up. Try using the following one line example:

ffmpeg -i oceans.mov -an -c:v libx264 -r 24 -preset fast -profile:v baseline -g 64 -keyint_min 64 -b:v:0 230k -maxrate 250k -s:v:0 304x128 -x264opts pic-struct:no-scenecut -movflags frag_keyframe -f ismv oceans-250k.ismv

It is not as neatly presented in documentation, i.e. with the scroll bar, but lends itself better to copy and paste.

Your previous command, may only have been ffmpeg -i oceans.mov -an -c:v libx264 -r 24 -preset fast (with the rest after the first \ being discarded by the shell), and as that contains no filename at the end, then that is why you would have received the error message that you did.

| improve this answer | |
  • I tried after taking \ out, still same error – TRD Feb 13 '15 at 7:14
  • @TRD - Did using the line that I provided above give the same error also? Does the input file (ocean.mov) exist? Try a simpler, or the simplest, version of the command with all the options stripped out, does that work? For example ffmpeg -i oceans.mov -acodec libfaac -ac 2 -ab 64k -ar 48000 -vn -f ismv oceans-64k.isma. Then add the (other) options one by one. My guess is an extraneous invisible character has been copied, such as a non-break space or a line separator, or a wrong hyphen. I will test this myself when I finish work. Let me know how you get on. – Greenonline Mar 10 '15 at 3:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.