101

I have a fresh installation of Ubuntu 14.10 on my laptop. It appears that letters are missing from files and folders, as well as menus and configuration windows. I'm not sure where to start in order to fix this.

enter image description here enter image description here

  • 2
    I have exactly the same problem on a DELL E7450 that's supposed to support Ubuntu officially. Running 14.04.2 LTS form a live USB right now. – Dan Dascalescu Mar 30 '15 at 3:30
  • 2
    See this answer: askubuntu.com/a/606583/395351 . Seems to be a confirmed bug for Intel HD5500 cards. – rob Apr 8 '15 at 16:42
  • I have the same probelem with Lenovo X250. this makes ubuntu useless – elhadi Jun 24 '15 at 10:04
  • 1
    I have sometime the same problem with Lenovo G50-80. After a restart this usually solved (untl next time). – jutky Aug 27 '15 at 10:19
  • 16
    I can't believe this issue happens still in 16.04. When is ubuntu going to fix this bug? – Claudiu Creanga Apr 10 '16 at 10:56
51

I had the same problem on my Dell Inspiron with 5th generation i5 running Ubuntu 14.04. Luckily I found an easy solution for this. First - install Ubuntu Tweak (following commands work for installing it):

sudo add-apt-repository ppa:tualatrix/ppa 
sudo apt-get update
sudo apt-get install ubuntu-tweak

Then, go to Fonts, change Antialiasing option from Subpixels Antialiasing (LCD screens only) to Standard Grayscale Aliasing and everything seems to work fine. In fact, the problem immediately appears/disappears on changing the setting, so seems this is indeed the possible cause.

Graphical Guide — Ubuntu Tweak tool

With missing letters, you might have trouble finding the "Antialiasing" label etc. Here's a graphical guide on how the tool looks with working fonts, to help you find where to click.

In the first window, you must pick the "Tweaks" tab in the top row (third from the left — i.e. the central one), then "Fonts" (first icon on the left in the first row):

Ubuntu Tweak -> Tweaks -> Fonts

Then, click the bottom choice bar, and choose the middle option (I can't show a screenshot with the choice bar opened, unfortunately, as Ubuntu doesn't seem to react to me pressing the PrtScr key then :-/)

Antialiasing choice bar

Graphical Guide — Unity Tweak tool

Similar guide as above, but for the Unity Tweak tool.

After starting the tool, click "Fonts" (right-most icon in the third row):

Unity Tweak -> Fonts

Then click the marked choice bar, and select the middle option when it opens:

Fonts -> Appearance -> Antialiasing

  • 6
    This can also be done via the gnome-tweak-tool for those using the GNOME desktop environment (or wm+gnome-settings-deamon, like myself) – user898763452 Sep 13 '15 at 1:00
  • 3
    On Ubuntu 16.04, and presumably earlier, this is unity-tweak-tool. – djvs Apr 17 '16 at 15:42
  • 3
    It seems to be only a temporary fix for me (after the next few suspends the letters disappear again) – groovy354 Jul 13 '16 at 10:26
  • 1
    Maybe I am missing something, but I can't find a way to do it through the gnome-tweak-tool. Could someone give me a hand? – user364819 Jul 13 '16 at 20:24
  • 2
    I had to increase my test scaling factor from 1.00 to 1.10 to make the unitu-tweak-tool fix actually work everywhere – emmagras Nov 16 '16 at 17:32
11

For me this usually happens (sooner) when I got a second display hooked up to the laptop. Changing the aliasing using ubuntu tweak only temporarily solves the problem. Same for changing the font size using ubuntu's displays.

Installing the Intel Graphics Installer for Linux (which is at version 1.1.0 now) doesn't seem to do anything at all. I ran the installer through the software center without any problems.

I have been using this workaround for a day now without any problems. On ubuntu 14.04:

Create or edit /etc/X11/xorg.conf Add the code below, save and reboot

Section "Device"
    Identifier  "Intel Graphics"
    Driver      "intel"
    Option      "AccelMethod"  "uxa"
EndSection
  • 1
    Still happening on 15.04 – tutuca Aug 31 '15 at 22:45
  • 2
    This helped me for a while, but after some time the problem returned. – jutky Sep 16 '15 at 19:32
  • 2
    @tutuca, it was happening on 15.04 for me, too, until I updated my kernel to 3.19.0-29-generic. Now it hasn't happened at all. – user898763452 Sep 17 '15 at 0:19
  • I fiddle a little with my fonts configurations and it got fixed. – tutuca Sep 17 '15 at 19:49
  • 2
    Note that AccelMethod UXA is the previous and slower one. – vorburger Jun 1 '16 at 9:39
5

It might be an driver issue. If you're using an Intel graphics, try installing the latest(1.0.8) Intel Graphics Installer for Linux, which supports 14.10. I had same problem with my 5th generation i5 laptop but it solved this problem.

5

I had the same problem on my new Dell laptop with Intel® HD Graphics 5500 (Broadwell GT2). If you had dependence problem when installing the above Graphic Installer for Linux, you can install GDebi Package Installer which can easily solve dependence issues.

Or first install GDebi

sudo apt-get install gdebi

Download the 64 bit driver for an X64 system or the 32 bit version for an X86.

wget https://download.01.org/gfx/ubuntu/14.10/main/pool/main/i/intel-linux-graphics-installer/intel-linux-graphics-installer_1.0.8-0intel1_amd64.deb

Finally, use GDebi to install that driver

sudo gdebi intel-linux-graphics-installer_1.0.8-0intel1_amd64.deb 
  • 3
    You don't need GDebi to install deb files. The Software Centre does that just fine. Double click on the deb file, or run software-centre intel-linux-graphics-installer_1.0.8-0intel1_amd64.deb. – muru May 14 '15 at 2:28
  • I don't know whether the Software Centre can automatically solve dependence problem. I am a new Linux user though. : ) Thanks for comments! – user304461 May 14 '15 at 2:35
  • That link is broken , recommend to link directly to 01.org/linuxgraphics/downloads – Einar Ólafsson Jul 5 '15 at 13:26
  • 2
    sudo dpkg -i intel-linux-graphics-installer_1.0.8-0intel1_amd64.deb then sudo apt-get install -f will also work – user898763452 Sep 13 '15 at 0:54
  • software center is super slow compared to gdebi – answerSeeker May 15 '17 at 4:47
1

I had the same problem, and found a post that suggested changing the font size of the "ubuntu" default font (had to install something called ubuntu tweaks to be able to do so). After changing the font size, everything was displayed correctly.

I still have some issues with my terminal blanking out once in a while, but just pressing enter a few times, and everything reappears. Most likely some sort of graphic driver bug, but at least the font size change fixed most of the problem for me

-1

It looks like the issue was fixed in Ubuntu 15.04. I've upgraded and the problem is no longer an issue.

During the upgrade I did notice that several AMD specific packages were installed.

  • 5
    Still happening at 15.04 – tutuca Aug 31 '15 at 22:45
  • 1
    No it did not fix it, I am just having this bug. It is the first time since installing 15.04, but it is not fun at all. – conualfy Nov 21 '15 at 21:14
  • 21
    still happening in 16.04 – vorburger Jun 1 '16 at 9:34
  • 13
    Still happening on 16.04 here too. – user364819 Jul 13 '16 at 20:26
  • still happening on 17.04 – Rishabh Agrahari Jul 7 '17 at 12:48
-1

Sometimes I have this issue using Ubuntu 15.04 too. A quick and dirty workaround consists of restarting X (sudo service lightdm restart)

Be aware that this kills all your open applications and you will lose any data that has not been saved.

protected by Community Oct 8 '15 at 13:36

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.