1

This has become quite nuisance as whenever I search in the URL bar in either Chrome or Firefox it always ask this in a notification bar below the URL bar. It only happens when I search a single word, like "hey" for example. I was wondering if this could be stopped as it seems to only happen in Ubuntu, but not Windows or Mint. It doesn't seem to be caused by extension however.

1

Your DNS is telling your browser that its a website. I'm going to assume that you have the default DNS settings in place and you are using your ISP's DNS.

The quick fix is to change your DNS to Google's public DNS

Instructions found here

I'll also include the steps for Ubuntu here

  1. In the System menu, click Preferences, then click Network Connections.
  2. List item
    • To change the settings for an Ethernet connection, select the Wired tab, then select your network interface in the list. It is usually called eth0.
    • To change the settings for a wireless connection, select the Wireless tab, then select the appropriate wireless network.
  3. Click Edit, and in the window that appears, select the IPv4 Settings or IPv6 Settings tab.
  4. If the selected method is Automatic (DHCP), open the dropdown and select Automatic (DHCP) addresses only instead. If the method is set to something else, do not change it.
  5. In the DNS servers field, enter the Google Public DNS IP addresses, separated by a space:
    • For IPv4: 8.8.8.8 and/or 8.8.4.4.
    • For IPv6: 2001:4860:4860::8888 and/or 2001:4860:4860::8844
  6. Click Apply to save the change. If you are prompted for a password or confirmation, type the password or provide confirmation.

If your distribution doesn't use Network Manager, your DNS settings are specified in:

/etc/resolv.conf
5
  • I don't know if this the case, and I know I should have mentioned this beforehand, but it seems this occurrence doesn't occur in Opera or some other browsers. I know this simple answer would be to use Opera, but honestly I'm not to fond of it. If it truly was because of my network settings, I don't see why this doesn't occur in other Browsers or Operating Systems. Feb 13 '15 at 20:17
  • @user364359 I see your point, but out of curiosity would you be willing to try changing your DNS settings. At the very least it rules out my suggestion and you wont break anything else switching to Google's public DNS :P Feb 13 '15 at 23:11
  • I've tried both Ipv4 and Ipv6 and each of the DNS addresses for the categories, but the problem still persists. Plus, the whole Google Public DNS worries my paranoid side, though my rational side knows it shouldn't. =( Feb 14 '15 at 5:23
  • Not a perfect solution but in chrome if you prefix your one word query with a question mark you will not get prompted. For example: ?help will just search for "help" and will not prompt you for redirection to http : // help Feb 16 '15 at 2:04
  • Thanks for your help. If you know anything more later on please tell me. I just find it strange how to only occurs in Ubuntu, in a few select browser, and now it's only occurring on a select group of random words. I also find it strange that it occurs on Firefox, Chromium, and Chrome but not Opera, which is based off Chromium. It doesn't make sense that it doesn't stop when I select the option to turn off all notifications either. I don't know, it just seems like something so small yet annoying should have a simple fix. Feb 16 '15 at 3:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.