1

I wanna to compile C++ code in this source https://github.com/jdeng/rbm-mnist I have installed clang 3.4, sudo apt-get install libmagickwand-dev, sudo apt-get install build-essential , and sudo apt-get install libmagickwand-dev.

I found that there isn't /usr/include/GraphicsMagick and Magick++.h locates in /usr/include/ImageMagick.

I have run this command clang++ --std=c++0x -o dbn -g -O2 demo.cc -lz -I /usr/include/ImageMagick -lGraphicsMagick++ but an error occurred, it is /usr/bin/ld: cannot find -lGraphicsMagick++

I have no idea because I already installed libmagickwand-dev, could you please help?

1

Use sudo apt-get install libgraphicsmagick++1-dev instead of sudo apt-get install libmagickwand-dev. It will work.

0

The library you need is located in the libgraphicsmagick++3 package (on release 14.10). You can use the package search feature of the ubuntu website to search for it.

Once installed, you may use dpkg or ldconfig to locate the library in the file system:

$ dpkg -S 'libGraphicsMagick++.so'

 libgraphicsmagick++3: /usr/lin/LibgraphicsMagick++.so.3

$ ldconfig -p | grep Graph
    LibgGraphicsMagick++.so.3 (libc6.x86-64) => /usr/lib/llibGraphicsMagick++.so.3

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.