I'm running Lubuntu-14.10-desktop-i386, and the printer install went seamlessly - system-config-printer found my printer on the network and recommended a driver. Unfortunately, that driver, and another I tried, result in a stream of blank pages instead of a test page. There is no specific WF-1110 driver in the current distro; the Epson WorkForce 1100 driver doesn't work (you'd think it would) and the recommended driver Epson WF-7018 Series - CUPS+Gutenprint v5.2.10 does the same blank-pages thing.

I'm not totally sure it's a driver issue (you'd think the WF-1100 driver would do the trick), so I'm wondering if there are other tweaks I should try.


I solved this, and figure others may benefit. Turns out you can download (from here) the generic Epson Linux driver package, called: epson-inkjet-printer-escpr_1.4.4-1lsb3.2_i386.deb (for my case, a 32-bit Ubuntu distro).

You have to install lsb, then this Debian package.

sudo apt-get install lsb
cd Downloads                       # or wherever the file you downloaded is
sudo dpkg -i epson-inkjet*.deb

After that, the system-config-printer tool finds the driver and you're all set.

  • Here's the page where you can find the download: download.ebz.epson.net/dsc/search/01/search/searchModule
    – Sam Hokin
    Feb 16 '15 at 18:04
  • Well, this isn't all that great. The printer works, but it prints very very light, and I can't find a way to darken it (including setting saturation to max with the advanced options under Lubuntu). If anyone has a tip on this little detail, I'd appreciate it! (It's essentially unusable with the lightness of printing that happens as a "default dot matrix printer", as I think this driver operates.)
    – Sam Hokin
    Feb 19 '15 at 16:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.