1

I have recently uninstalled ubuntu-web-browser from my ubuntu 14.04 using synaptic package manager as I don't use it. Now I can't start vlc media player nor play any file using vlc. It sort of opens and then immediately closes down automatically. I get this when I try opening vlc in the terminal:

VLC media player 2.1.4 Rincewind (revision 2.1.4-0-g2a072be)
[0x8f6d910] main libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
[0x8ff7368] skins2 interface error: no suitable dialogs provider found (hint: compile the qt4 plugin, and make sure it is loaded properly)
[0x8ff7368] skins2 interface error: cannot instantiate qt4 dialogs provider
[0x8ff7368] [cli] lua interface: Listening on host "*console". VLC media player
2.1.4 Rincewind
Command Line Interface initialized. Type `help' for help.

I have installed ubuntu anew twice because of this vlc problem. But only this time I realised it was due to uninstallation of ubuntu-web-browser that vlc stops working. I know this because I tested that vlc runs before I uninstalled the mines and the other games and then ubuntu browser. But after uninstalling these, vlc won't start. So I suspect uninstalling these is the cause.

Now my question is if vlc depended on some packages that were uninstalled due to uninstallation of some other stuff, then why would those packages be removed even when vlc had dependency on them? (am I wrong, or missing something?) How are the dependencies maintained during uninstallation? Also, how can I get vlc running without installing ubuntu again?

New absurd observation:

I uninstalled the games in ubuntu using the following command found here

sudo apt-get remove --purge gnome-mahjongg gnomine gnome-sudoku aisleriot

and same problem occurs !!! Vlc stopped working, and same error message in terminal! Anyone knows what the problem is, and how to solve it?

Yet another absurd observation

This time I uninstalled the games using apt-get remove, but vlc keeps working. Then unity-tweak-tool gives error message while starting. This was solved by installing unity-webapps-service as said here. Then vlc stops working, giving that message again!

4
  • In my system, gnome-sudoku gnome-mahjongg aisleriot is not installed, but vlc was working. after uninstalling gnomine still worked. I think, you have very weird repository configuration – Anwar Feb 20 '15 at 16:31
  • @AnwarShah Then why don't you please tell me how I can remove weirdness from my repository configuration? Added another weird observation in the question. At this point I am tempted to say ubuntu's dependency maintenance stinks! – Sнаđошƒаӽ Feb 21 '15 at 2:33
  • This is not Ubuntu's dependency maintenance problem, rather it's of very high quality. Your problem is very specific problem which can't be reproduced here. You might have other reasons beside what you described here. Because, it is just working fine in here without those games. I suggest to completely removing vlc and installing it from official repo by disabling your local one – Anwar Feb 21 '15 at 5:35
  • If the software repositories are the problem, then this answer should show how to "reset" your software sources.list's / repositories. Basically, you erase (BACKUP) all the old ones, and replace with the defaults (obtained from a nice webpage or reset with the software properties/sources gui program) – Xen2050 Feb 21 '15 at 10:49
1

You asked,

Now my question is if vlc depended on some packages that were uninstalled due to uninstallation of some other stuff, then why would those packages be removed even when vlc had dependency on them?

Answer: No, apt package management system, which Ubuntu uses, doesn't remove a package upon which other packages depend, even if you want to uninstall some of them. That would be silly. For a typical example, consider package libc6. It's one of the core packages of Ubuntu and hence, lots of packages depend on It. But uninstalling one or two from them, won't remove libc6.

Moreover, If you deliberately want to remove a package, upon which lots of packages depend, Ubuntu or specifically apt system will warn you before actual uninstall. But if you wish, you can uninstall that package too! In this case, the other packages which depend on this, also get removed.

Case 1:

Let, There be three packages named core-x, a and b. a and b both depend of core-x package. Now, if you try to remove package b, core-x will not be removed, since it is still needed for functioning of a.

Case 2:

Again consider our fictitious packages. If you now try to remove core-x package by putting in apt-get remove line, core-x will get removed with both a and b package, because these two (a and b) won't function without core-x.


Your second question was -

how can I get vlc running without installing ubuntu again?

For this, try removing vlc with purge option and re-install again. A command like below will do the job.

sudo apt-get --purge autoremove libvlc5

and install it with

sudo apt-get install vlc

Bonus: By using libvlc5 instead of plain vlc, you are just experiment with Case 2 where you removed a package, upon which other packages depend.

Hope this helps.

7
  • Sorry, that didn't solve the problem. Still same condition. I did exactly what you said. BTW, is there any way to get that creepy ubuntu web browser back? I think that will solve the problem. – Sнаđошƒаӽ Feb 13 '15 at 5:04
  • Install it with sudo apt-get install webbrowser-app. But I tested uninstalling it. Vlc works. You can try – Anwar Feb 13 '15 at 5:09
  • I get this message for sudo apt-get install webbrowser-app Package webbrowser-app is not available, but is referred to by another package. This may mean that the package is missing, has been obsoleted, or is only available from another source However the following packages replace it: qtdeclarative5-ubuntu-ui-extras-browser-plugin E: Package 'webbrowser-app' has no installation candidate – Sнаđошƒаӽ Feb 13 '15 at 5:15
  • Then install that package instead. It sounds weird! I am using 14.04 and it is in my repository! Check if you have all necessary repository enabled – Anwar Feb 13 '15 at 5:22
  • Please explain what you mean by all necessary repository. I have one local repository and I have enabled that in the file /etc/apt/souces.list. Otherwise I didn't change anything else in that file. And you said to install "that" package. If you mean this qtdeclarative5-ubuntu-ui-extras-browser-plugin, then I tried but it says it is already the newest version – Sнаđошƒаӽ Feb 13 '15 at 5:32
1

Vlc problem is solved when I did these:

  • completely removed vlc
  • removed the driver of my ZTE modem (ZTE MF-193E) that uses qt plugins to run
  • installed vlc again; and vlc runs normally

Later I installed the modem driver again, but this time vlc kept working!

1
  • 1
    If you still need a specific answer - please ask another question. Accepting an answer - even if its your own should be the final solution. thanks. – fossfreedom Feb 25 '15 at 13:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.