4

I am trying to launch loffice or localc via an established ssh connection (ForwardX11 enabled). It does however fail to show the loffice gui / splashscreen on the computer from where I run my ssh session. The loffice application runs in the remote bash but without any command line output.

All other gui applications like xterm, gvim, PyQt5 scripts work fine. I also tried to run

/usr/lib/libreoffice/program/soffice.bin

directly, but to no avail. (loffice is a shell script redirecting to another shell script, which as far as I understand eventually launches soffice.bin.)

Also without any success I tried:

loffice --display ${DISPLAY}
  • 2
    If there's a running LibreOffice program on the remote system, have you tried killing it? – muru Feb 12 '15 at 12:42
  • Yep there was a running soffice.bin. Thanks. – tssch Feb 12 '15 at 12:44
  • 1
    The --display switch was what I needed. I noticed (via x11vnc) that there were instances running on the default display, but even after killing them, LibreOffice started on DISPLAY 0.0 – Tomasz Gandor Apr 19 '17 at 11:12
5

If a LibreOffice window is open, it opens a window in the display of that process. Therefore one way would be to kill any running LibreOffice processes.

  • >:) Good one!!! – Fabby Feb 16 '15 at 16:20

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.