ACPI PCC Probe Failed is the error that pops up instead of the default GRUB loader after I updated my kernel to 3.19.

I searched around and couldn't find much information except that it is a known error and it is registered in kernel.org's launchpad https://bugzilla.kernel.org/show_bug.cgi?id=92551. My question is, is anyone else facing it?, what are the impacts of this? And if only an update in the future can fix it, any suggestions or safety tips till then?

  • 4
    I have this error after upgrading to Vivid Vervet. Machine displays error and hangs, will not proceed any further with boot. Pretty catastrophic, suggests that message not entirely harmless (despite conversation below)? – CnrL Apr 24 '15 at 13:47
  • My question is, is anyone else facing it? Yes. Me too! – Cornelius Apr 24 '15 at 14:23
  • Stuck on it too – yPhil May 3 '15 at 10:02
  • Same problem after I upgraded to kernel 3.19.0-21 – Tarik Jun 21 '15 at 15:12
  • 1
    @Sardinha94410, you can find Ubuntu kernels at kernel.ubuntu.com. I downgraded to v3.18, kernel.ubuntu.com/~kernel-ppa/mainline/v3.18.17-vivid – Lordbalmon Jul 8 '15 at 16:52
up vote 24 down vote accepted

Apparently it is a harmless message related to a 'PCC' driver:

So it looks like you build the PCC mailbox driver which is new in 3.19-rc and that driver fails to load, because it doesn't find hardware to work with.

The message is harmless, but it also is not useful. The driver in question seems to be overly verbose to me in general.

That is what I gleaned from this conversation.

  • I see, so the GRUB disappearance is totally unrelated you think? It is possible, I forgot to run the update-grub command after updating the kernel, I will try it and get back soon. – Lordbalmon Feb 13 '15 at 15:29
  • 1
    @Lordbalmon if you update or install the kernel using apt-get or any other ubuntu package management or update tools you shouldn't need to run update-grub, the system should run that as part of the installation unless you compiled your own kernel or something. – mchid May 13 '15 at 6:04
  • @mchid, that is possible, though it was not a compiled kernel, I downloaded the .deb files and tried manually updating it. – Lordbalmon May 13 '15 at 11:43
  • @Lordbalmon You do know you can manually perform updates with sudo apt-get update followed by sudo apt-get dist-upgrade correct? If you are not running vivid and want to run kernel 3.19 I understand you have to download it but otherwise, you should be using the package manager. – mchid May 13 '15 at 12:08

ACPI PPC probe failed. is related to a new ACPI interface PCC (Platform Communication Channel), which is defined by UEFI.

You may see this in your output of journalctl:

$ sudo journalctl
Aug 16 23:10:55 x kernel: **PCCT header not found.**
Aug 16 23:10:55 x kernel: **ACPI PCC probe failed.**

These are the returns if the code does not find the ACPI interface which only some very new devices have or if it actually fails to read/write to the interface if it is present. The code was written for upstream releases. If you read the emails in the filed bugs below you will find information that supports my statements and you can read the return messages in the code itself in the GitHub link above.

http://permalink.gmane.org/gmane.linux.power-management.general/56400 http://comments.gmane.org/gmane.linux.acpi.devel/73411

I hope this helps to clarify some things.

I [Solved] the problem by changing the motherboard settings. For my motherboard (access this at boot, not through Ubuntu) I went to Advanced > System Agent > Graphics > iPGU Multi-Monitor and set it to "enable." I left all of the other system agent graphics settings on auto. After that the boot and ACPI problems (including a shutdown hang, crashes, freezes, monitor shutdown) stopped.

Every motherboard vendor has its own settings. The problem seems to be a northbridge snafu between the onboard Intel graphics and the Nvidia card. So, it may takes several visits to your motherboard setup to find the right combination of settings that works for you. This problem was new to me under 15.04, and may be due to a change in how Ubuntu handles such graphics disputes.

(My motherboard is ASUS P8Z77-V LX LGA 1155 Intel Z77)

  • similar case, ROM problem, I changed "ACPI HPNET (disabled)" to enabled... but not work... – Peter Krauss Oct 1 '15 at 20:44

I've filed a bug for this with an upstream fix to turn this error message into a debug message, this will hopefully land in the next kernel SRU release cycle

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1524930

protected by Community May 2 '15 at 7:04

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.