The monitor can go into a flickering mode which is easily triggered by going into "Search your computer and online sources." It is especially bad if other applications are open like Chrome (perhaps opengl related). It can go into a loop that will get so bad that a reboot is necessary. It is not reliable.

I have tried disabling (in compiz-settings-manager) "Unredirect Fullscreen Windows." Also tried increasing the "Launcher reveal Pressure."

So far, since I have only seen this triggered by using the "Search your computer and online sources," I'm wondering if there is a second interface (perhaps text only) that users can use until there is fix..

In the mean time, I have made it stable by decreased the display resolution from 3840 x 2160 to 1920 x 1080.


lspci | grep VGA 00:02.0 VGA compatible controller: Intel Corporation Broadwell-U Integrated Graphics (rev 09) 08:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Opal XT [Radeon R7 M265] (rev ff)

  • I noticed in my case, that having chrome viewable (unless I drag the title bar down to the bottom of the screen) will trigger the blackout while Firefox does not. Also, I had a high-res background I had to replace back to the default Ubuntu background help. – jcalfee314 Jul 20 '15 at 21:20
  • I found various websites will trigger the issue especially in Chrome. Visiting http://www.ripe.net/ (chrome only) for more than 10 seconds is so bad closing the window did not resolve the problem. I tried exiting to the console A+C+F1 then coming back A+C+F7. Only a reboot stopped the flicker. – jcalfee314 Oct 1 '15 at 14:26
  • The workaround answers just don't work (but thanks for the info!). How long until we find the real bug, this is not acceptable I could have learned C++ and kernel code and fixed this by now... – jcalfee314 Oct 1 '15 at 14:27

Possibly related: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1407913

Try going into CompizConfig Settings Manager and searching for workarounds.

Click on the only result:

enter image description here

then scroll down to the bottom and select the Force full screen redraws (buffer swap) on repaint check box:

enter image description here

Close CompizConfig and reboot and see if this helps.

This resolved a screen flicker I was having with my NVIDIA GTX 750 Ti, so I'm not totally sure it will work, seeing as you don't give your GPU (if any.)

However, it never hurts (well, normally) to share - hope this helps :)

  • It may have helped but the flickering is still very bad. I'm loosing visibility to the entire desktop. I'm not sure if the machine is stable yet. – jcalfee314 Feb 11 '15 at 16:43
  • 1
    Hrm. I don't know then :( What's your GPU? Run lscpi | grep VGA and post the output. – RPiAwesomeness Feb 11 '15 at 16:53
  • lspci | grep VGA 00:02.0 VGA compatible controller: Intel Corporation Broadwell-U Integrated Graphics (rev 09) 08:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Opal XT [Radeon R7 M265] (rev ff) – jcalfee314 Feb 11 '15 at 22:02
  • 1
    Ah. So, it's a desktop with a dedicated GPU? If it was an computer with Intel integrated graphics only, I'd have suggested installing the Intel graphics drivers, but since you've got that AMD GPU you'd probably want to try installing the Catalyst drivers for your GPU. – RPiAwesomeness Feb 11 '15 at 22:47
  • Laptop .. I ran the intel installer (01.org/linuxgraphics/downloads/2014/…). It said since I don't have an I9 (I have an i7) there is nothing to upgrade. Do you think the bug is in that driver? – jcalfee314 Feb 12 '15 at 12:57

I had the same problem with this computer running Fedora 21 and Gnome shell at 3840x2160. I came across this discussion that lead me to the solution. https://bugs.freedesktop.org/show_bug.cgi?id=83497. Passing the option i915.enable_ips=0 to the kernel upon boot completely solved the problem for me.

  • Neither i915.enable_IPS=0 or i915.enable_ips=0 worked. – jcalfee314 Mar 4 '15 at 23:34
  • 1
    i915.enable_IPS=0 Not work for me Ok i915.enable_ips=0 work – user425917 Jul 2 '15 at 20:35

This is a kernel problem that was fixed on 6-4-15 (see link that knutsondc provided). I have the same machine and problem. I was able to solve the problem by installing a unstable kernel image from http://kernel.ubuntu.com/~kernel-ppa/mainline/drm-intel-nightly/ (i used the 6-25 image). After installing the kernel the search, chrome, and keepass2 no longer have the blackout or flickering. The OS now freezes if I change the zoom level, but if I reboot the new zoom holds. So after all that I have 4k video in Ubuntu for now.

  • Kernel 4.2.0 did Not resolve the problem for me. – jcalfee314 Jul 20 '15 at 21:20

Not the answer you're looking for? Browse other questions tagged or ask your own question.