1

I had a working Ubuntu 11.04 installation, alongside Windows Vista. To avoid a triple upgrade, I decided to do a fresh install of 14.04 from a USB drive. However, after rebooting, the only OS choices I have were Windows and Ubuntu 11.04!

I searched for a directory called "/boot", and I found one, containing vmlinuz-3.13.0-32-generic (which I guess is 14.04) and all the other stuff I installed along with it, on a new partition that was apparently created during the installation, in the file "/media." But how do I get it to show up in the list of operating systems I can choose from, when I reboot the computer?

I tried update-grub (not "grub-update")( but it didn't do anything. I also tried the "try-out" version of 14.04 using my stick drive and update-grub there, but of course that does nothing because nothing is changed permanently once I shut down. Why is my new 14.04 install not showing up and how can I get it?

My system has 3 hard drives and a DVD-Rom drive:

/dev/sda, /dev/sdb, /dev/sdc and /dev/sdh

4
  • ByteCommander, what does "with the new Ubuntu as a target" mean when I reinstall GRUB? – JEG Feb 11 '15 at 18:25
  • I mean that you would use the partition you chose as root (/) for your new Ubuntu system as main/source/target partition. – Byte Commander Feb 12 '15 at 21:09
  • Answer deleted. This is a highly complex system with multiple OSes and 3 hard drives and you forgot to mention this? Please edit your question and give us a lot more information to work with... – Fabby Feb 15 '15 at 16:40
  • The "multiple OSes" are just Ubuntu 11.04 and Windows, both of which I use, plus some older Ubuntus that I upgraded from and never use any more but that I don't know how to get rid of. The hard drives are the Hitachi one that came inside my HP computer, the "HP Pocket Media Drive" (an external HD) that also came with my computer,and a 1 TB HD that I installed later. I don't know what other information I can give you. – JEG Feb 15 '15 at 17:15
1

Run grub-update from your Ubuntu 11.04 that is if grub was the boot manager. Otherwise, you'll need to fix that from the windows boot manager.

2
  • Yes, grub was the boot manager. But when I run sudo update-grub, it finds only the kernels in /boot. But the kernel of 14.04 is in a new partition, /media/495..., that was created when I installed 14.04, and which contains all the files for 14.04. Is there some way to link all of these into /, or copy them there, so that install-grub will find them? (This is directed to @ByteCommander also.) – JEG Feb 12 '15 at 14:17
  • I tried to open "Show 5 more comments," but all I get (repeatedly) is "An error occurred while fetching comments." How do I read the 5 more comments? – JEG Feb 15 '15 at 17:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.