0

I have a WD 1 tb blue and a SanDisk 120 GB SSD, obviously booting from SSD. I can not for the life of me figure out how to see both of them in the Files. I got close one time but there was an eject button next to my internal HDD. Help is much appreciated.

  • Hi and welcome on AskUbuntu.com! :-D Can you please be a bit more specific about your question? Do you have problems with mounting the device (it should get automatically mounted if you click its symbol in Nautilus=Files) or does it not show the device symbol in the left part of Nautilus at all? And are there any partitions on the second drive, or is it unpartitioned? Because you only can mount and access partitions, not drives. – Byte Commander Feb 10 '15 at 15:01
  • Idk what Nautilus is, this is my first day with Ubuntu. More specific, I can see that the WD Blue HDD is there in the BIOS but it does not show in the files section. I partition the drive once and that is when the eject button showed next to the drive. I didn't like it so I deleted the partition. – Trend Feb 10 '15 at 15:11
  • I said "Nautilus" = "Files". The file browser you use by default in a fresh Ubuntu installation is called Nautilus, although in the user interface, it is mostly described as "Files". - And that eject button always appears when you automatically mount the partition by just clicking on it in Nautilus. This is right. If you want you can automatically get it mounted at boot time. Then you could also mount it into any directory you want. – Byte Commander Feb 10 '15 at 15:24
1

If your secondary HDD is an external drive you have to first mount it.

Check out this guide.

Summary:

  1. Open the "Disks" application from the dash.

  2. Select the disk you want to manage. Click the option gear wheel.

  3. If the drive is formatted you can just mount it. Otherwise you will have to format it as NTFS. CAUTION: Formatting erases all data on your drive!

  4. After formatting click the gear wheel again and select "Edit mount options"

  5. Then turn Automatic Mount options off and select "Mount at startup"

The mount point (i.e. folder your drive will be on) you select must be created if you haven't done so already.

| improve this answer | |
  • I meant to say "internal". – Trend Feb 10 '15 at 14:57
  • I would still follow a similar process to mount the internal drive if it's not recognized by Ubuntu out of the box. – Bar Feb 10 '15 at 14:58
  • 1
    While this link may answer the question, it is better to include the essential parts of the answer here and provide the link for reference. Link-only answers can become invalid if the linked page changes. – Luís de Sousa Feb 10 '15 at 15:26
  • 1
    Are you using Ubuntu only on this machine or do you dual-boot with Windows? If Ubuntu is the only system, you should use its default file system ext4 for formatting and not NTFS. You only would need this for a partition that has to be accessible from both Windows and Ubuntu. And for this for beginners it might be better to use FAT32 instead of NTFS, because it can cause less problems with permissions etc... – Byte Commander Feb 10 '15 at 21:20
  • 2
    If you can, avoid NTFS like it's the plague. It's inefficient and breaks far too often. If you need Windows compatibility, you should really use FAT32. If you aren't using Windows, It is highly recommended that you use either EXT3 or EXT4. It contains almost all of the features of NTFS, with the stability of all things Linux. – Kaz Wolfe Feb 10 '15 at 21:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.