3

I installed 14.04 a month ago and have not been able to get my Nvidia graphics card to work since that time. Currently the system thinks it is using the Nvidia driver. Output of lshw -c video is as follows :

description: VGA compatible controller
   product: NV36 [GeForce FX 5700]
   vendor: NVIDIA Corporation
   physical id: 0
   bus info: pci@0000:01:00.0
   version: a1
   width: 32 bits
   clock: 66MHz
   capabilities: pm agp agp-3.0 vga_controller bus_master cap_list rom
   configuration: driver=nvidia latency=32 maxlatency=1 mingnt=5
   resources: irq:16 memory:f8000000-f8ffffff memory:e0000000-efffffff memory:f9000000-f901ffff

and the Additional Drivers tab in Software Updates says my NV36 (Geforce FX5700) is using Nvidia legacy driver version 173.14.39.

But the computer graphics is terribly slow, ie CPU is pretty much running at 100% and the System Overview tells me I am using Graphics Driver Gallium 0.4 on llvmpipe(LLVM 3.5, 128 bits).

I have read the answers to many similar problems in askubuntu and I have tried all the likely solutions but without success. Can anybody suggest anything to try? I am not a very experienced Linux user so it has to be a fairly detailed answer (sorry about that).

  • sounds as if your hardware does not support 3d graphics directly with the nvidia driver , thus falls back to llvm pipe. File a bug report with nvidia as it is closed source driver, not much we can do. – Panther Feb 10 '15 at 2:01
  • Thank you bodhi.zazen. I think I will just upgrade my system and trust that Ubuntu will work on whatever I get. I give up on trying to make it work on this system. Although it is strange to me that it worked OK on Ubuntu 12.04. It only has a problem since I upgraded to 14.04 – Douglas Evans Feb 12 '15 at 6:47
  • There have been a lot of changes to both the kernel and the graphics stack since 12.04 and changes are anticipated to continue. Ubuntu does not maintain the closed source nvidia driver. If you want the nvidia driver to work with Ubunru (Linux) you need to file a bug report with nvidia or ask them to open source the driver. It is just wrong for you to complain to the Ubuntu maintainers about the nvidia driver. – Panther Feb 12 '15 at 15:56
2

If you look at your NVidia card compared to modern equivalents I would say: disable it in the BIOS if a laptop, remove it from the PC if a desktop and run Xubuntu (or Lubuntu). Your performance is going to be much better in that case.

The only other way is to buy a new one. (Sorry to be the harbinger of bad news)

| improve this answer | |
  • As you're a reputation 1 user: It's not because you don't like the answer to your question, that you should forget to click the grey check-mark under the "0" at the left of this text, which means "yes, this answer is valid"! ;-) – Fabby Feb 12 '15 at 19:06
0

Your Ubuntu is using Nvidia driver for the card, but that doesn't mean Ubuntu is using Nvidia card. Maybe you didn't switch to Nvidia card after installing the propriety driver.

Instructions on how to switch between Intel and Nvidia card can be found on my blog: https://www.linuxbabe.com/desktop-linux/switch-intel-nvidia-graphics-card-ubuntu

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.