I was messing with the display options, and seriously messed something up. Now my display looks like this:

enter image description here

I don't see any obvious solution in the display settings. How can I fix this? What additional information should I provide?


After I run xrandr I get this:

Screen 0: minimum 320 x 200, current 2390 x 768, maximum 32767 x 32767
LVDS1 connected primary 1366x768+0+0 (normal left inverted right x axis y axis) 309mm x 174mm
   1366x768       60.0*+
   1360x768       59.8     60.0  
   1024x768       60.0  
   800x600        60.3     56.2  
   640x480        59.9  
VGA1 disconnected (normal left inverted right x axis y axis)
HDMI1 disconnected (normal left inverted right x axis y axis)
DP1 disconnected (normal left inverted right x axis y axis)
VIRTUAL1 disconnected (normal left inverted right x axis y axis)
VGA-2 connected 1024x768+1366+0 (normal left inverted right x axis y axis) 0mm x 0mm
   1024x768       60.0* 
   800x600        60.3     56.2  
   848x480        60.0  
   640x480        59.9  
  1024x768 (0x43)   65.0MHz
        h: width  1024 start 1048 end 1184 total 1344 skew    0 clock   48.4KHz
        v: height  768 start  771 end  777 total  806           clock   60.0Hz
  800x600 (0x44)   40.0MHz
        h: width   800 start  840 end  968 total 1056 skew    0 clock   37.9KHz
        v: height  600 start  601 end  605 total  628           clock   60.3Hz
  800x600 (0x45)   36.0MHz
        h: width   800 start  824 end  896 total 1024 skew    0 clock   35.2KHz
        v: height  600 start  601 end  603 total  625           clock   56.2Hz

But I still don't know what to get rid off. I think HDMI1 part is the problem because that's what I was messing with.


There is a known bug for Intel Baytrail graphic, also for a nVidia GeForce GT 630M [10de:0de9] graphic card.

If you're using the nVidia graphic card, the solution is easy, just install the proprietary driver from the "Additional Drivers"

Another workaround is to edit your "/etc/default/grub" file, change




(Since the bogus unknown display is connected to VGA2 in your case)

After that, run sudo update-grub and reboot


| improve this answer | |
  • I used the second approach and it fixed the problem. Thanks a lot! – Akavall Feb 12 '15 at 3:04
  • I'm on Ubuntu 18.04.3 LTS and have NVIDIA GeForce 410M. Updating the driver by NVIDIA driver metapackage from nvidia-driver-390 (proprietary, tested) from Software & Updates > Additional Drivers solved the issue. But then when I played videos, I had only the sound; it's all black! I gave up the driver update and used the second approach. – mrmowji Jan 20 at 15:12

Updating your drivers fixes it.
sudo ubuntu-drivers autoinstall (selects recommended drivers for you)

In my case it was Nvidia.
You can also go into Additional Drivers and select a propriety driver yourself.
After updating, it changed to "(propriety, tested)" itself.

Don't forget to restart.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.