I would like to stream music from my Ubuntu 14.10 machine to Airplay speakers. I followed the instructions here. After doing so, I can see the Airplay speakers to which I'd like to connect in both System Settings>Sound and/or Pulseaudio Volume Control. I can even select them in those settings.

HOWEVER, when I select the Airplay speakers in either System Settings or Pulseaudio, two things happen:

  1. The media player pauses. This happens in any media player: FireFox playing Pandora.com or Pithos or any other. Somehow, simply selecting the Airplay speaker pauses the player, and you cannot restart it. This happens every time the Airplay speakers are selected (note: I've tried this with numerous AirPlay speakers, so they are not the problem).
  2. The volume for the regular speakers is set at 0. No idea why.

Most guides that I've read say that all you need to do is what is described in the link -- essentially install Pulseaudio Volume Control and Pulseaudio Preferences, then enable Airplay in the latter.

But it doesn't work for me. I've tried this on two different installs of 14.10, with the same fail. This guy seemed to have a similar problem, but no one responded to his post.

Please help me get this to work? It's killing me.

  • Pulseaudio only supports the old RAOP protocol (aka AirTunes). The newer RAOP2 protocol needs considerable hacks to get it working. In case your speakers also support DLNA see: askubuntu.com/questions/187086/…
    – Takkat
    Feb 10, 2015 at 10:40
  • Takkat, that totally worked! Since I am trying to use Ubuntu to stream music to an old Android phone (which will be connected to speakers), DLNA works great.
    – Rsync
    Feb 15, 2015 at 18:25

1 Answer 1


Takkat provided the answer as a comment, so I am writing this "answer" to close out my question. Basically, AirPlay is not currently functioning with Pulseaudio without hack. BUT if DLNA is available on your speakers, which they are on any old Android phone connected to speakers, you can do this:

sudo add-apt-repository ppa:qos/pulseaudio-dlna
sudo apt-get update && sudo apt-get install pulseaudio-dlna

NOTE: the last command turns it on

NOTE2: dependencies for pulseaudio-dlna are listed here

Then you can open either PulseAudioVolumeControl, or just Settings>Volume and select your device.

I'm using BubbleUPnP on my Android. Please note that you need to turn on BubbleUPnP on the Android before you start pulseaudio-dlna, else it won't be able to see the renderer.

  • Been looking for this for hours, great job. Seems to take a long time to pick up audio changes though (~10 seconds), anyone else experiencing this? Jul 14, 2015 at 17:09
  • 3
    Great, this works for me to stream audio to my Pionner sound sound system. Only remark: the first command sould be: sudo add-apt-repository ppa:qos/pulseaudio-dlna Oct 31, 2015 at 13:19
  • Seems like, unfortunately, this is still true at least for some devices, in the latest Ubuntu 21.10. I have a SONOS Play 5 speaker. After installing paprefs & pulseaudio-module-raop, then restarting pulseaudio, I get exact same symptoms as the topic-starter. I didn't want the DLNA workaround since I am able to play my music from the iphone, just wanted to have the same ability from the laptop... Sigh... Nov 20, 2021 at 19:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.