4

I am running Ubuntu 14.04.01 LTS on an Acer V Nitro laptop which has an Intel Dual Band Wireless 7265 controller. The driver version is 3.13.0-45-generic with firmware 22.24.8.0. The connection is stable for 30-40 minutes and after, it disconnects. Are necessary several reconnect attempts, sometime a restart in order to reconnect to the WiFi network.

Did anyone face this issue with this controller? What do you recommend to diagnose the issue?

4 Answers 4

5

The root cause is described in this blog post It seems that there are some bugs in the Intel iwlwifi driver for 802.11N protocol for the kernel/firmware versions 3.13.0-45-generic/22.24.8.0. The temporary solution it is to disable 802.11N which is an work-around until the issue will be fixed. That means that I will not use the full capacity of the 7265 controller, which will be limited to 54MBs.

sudo sh -c 'echo "options iwlwifi 11n_disable=1" >> /etc/modprobe.d/iwlwifi.conf'
5
  • Just wanted to say I had the same issue in Ubuntu 15.04 on a Lenovo X1 Carbon (Latest) and this workaround resolved the issue for me.
    – levlaz
    Jul 5, 2015 at 14:49
  • 54MB/s is way better than the intermittent and incredibly frustrating 0MB/s I have been experiencing... especially given I am paying for 250...
    – Ajax
    Jul 27, 2016 at 6:14
  • Hm. It seems the disable=8 option works better for me; on ubuntu 16.04
    – Ajax
    Jul 27, 2016 at 7:11
  • I also have the last supported version of firmware for this device from wireless.wiki.kernel.org/en/users/drivers/iwlwifi Note how 7260 and 7265 are explicitly called out for "not going to receive any updates anymore". Boooo.
    – Ajax
    Jul 27, 2016 at 7:13
  • Actually, I was able to download newer firmware from the git repo, which made my connection both reliable and faster, without these workaround. I posted the full instructions as an answer, which I suggest anybody reading this tries if they have a 7260, 7265 or 7265D device
    – Ajax
    Jul 27, 2016 at 7:29
3

A lot of Intel wifi cards exhibit this issue until you echo "options iwlwifi 11n_disable=8" | sudo tee -a /etc/modprobe.d/iwlwifi.conf and reboot

3
  • zeroset.mnim.org/2014/04/22/… I looked to the traces from /var/log/syslog and they match the same use-case.
    – garzanti
    Feb 9, 2015 at 22:12
  • 1
    It didn't helped, but your hint sent me to the blog above, which looks my case too. I've set 11n_disable=1, and it should work...
    – garzanti
    Feb 9, 2015 at 22:39
  • Good and kernel and firmware updates might help as that is one of the newer intel wifi cards
    – Jeremy31
    Feb 9, 2015 at 23:28
1

Wheeee! After a couple hours putzing around on the Internet, I found a solution that works for 7260/7265 with even newer firmware for 7265D devices.

Per the official driver page: https://wireless.wiki.kernel.org/en/users/drivers/iwlwifi

7260 and 7265 will not be supported by the newest firmware versions: the last firmware that was released for these devices is -17.ucode. Bug fixes will be ported to -17.ucode. Note that 7265D can run later firmware versions. In order to determine if your 7265 device is a 'D' version, you can check the dmesg output:

Detected Intel(R) Dual Band Wireless AC 7265, REV=0x210 The revision number of a 7265D device is 0x210, if you see any other number, you have a 7265 device.

So, I ran dmesg | grep Wireless and saw I did have device code 0x210.

As such, I was able to use https://github.com/OpenELEC/iwlwifi-firmware/blob/master/firmware/iwlwifi-7265D-21.ucode

Edit: This file is now gone. MAYBE https://github.com/OpenELEC/iwlwifi-firmware/blob/master/firmware/iwlwifi-7265D-22.ucode may work, but I have not tested this.

**If you do not have a 7265D per the dmesg command above, instead use: ** https://github.com/OpenELEC/iwlwifi-firmware/blob/master/firmware/iwlwifi-7265D-17.ucode

Edit: This file is also missing. Either find a new driver that works, or search for old files in git history: https://github.com/OpenELEC/iwlwifi-firmware/commits/master/firmware

Next, I had a look in /lib/firmware, and noticed that I only had the -16.ucode file. So, I went to the git repo, downloaded the file from git, then used: sudo cp ~/Downloads/iwlwifi-726* /lib/firmware restarted my wifi, and actually got a usable connection!

Note that I tried both 11n_disable=8 and 11n_disable=1 (tried each one separately) to no avail. With this updated firmware, I was able to remove these workarounds.

4
  • Note that if your kernel version is < 4.3, you probably won't be able to load the latest firmware, but I don't have an old enough install to test.
    – Ajax
    Jul 27, 2016 at 7:39
  • 1
    I had the same issue in Ubuntu 18.04 and tried this. It seems though that I already have any iwlwifi-726* files from the github repository in /lib/firmware. Yet my wifi remains stubbornly unusable! Sep 20, 2019 at 14:19
  • 1
    A couple hours? It took me a couple weeks at least. Ubuntu 18.04 (actually elementary OS 5.1.3 Hera) linux kernel 5.3.8-050308-generic Asus Zenbook ux303. lshw -c net showed me 7265D-29 firmware loaded. Downgraded to 7265D-22, so far, what a relieve. Thank you so much. Shame on you intel. Apr 15, 2020 at 16:55
  • 1
    I experience similar issues with 7265D-59 and iwlwifi driver version 5.4.0-70-generic. The links point to nowhere but I guess that the versions are outdated anyway
    – max
    Mar 30, 2021 at 7:41
-1

I have a non-software solution for that. Warming up the machine. Yes you're seeing it right. In the beginning my laptop (ASUS UX305FA) could not connect to some specific WIFI device. one day I just put it in the soft-case and brought it around, the machine was a little bit warmer than before. Suddenly it connected to the WIFI network which was not able to link. This is more like a magic trick but it works for me... and I am using that WIFI spot now.

4
  • :) interesting solution, but the issue is already fixed with the new kernel deployed in the Ubuntu 15.10 version. The driver is workin quite fine now.
    – garzanti
    Feb 23, 2016 at 13:30
  • That's nice to hear. But I am the fan of LTE so I will look forward to 16.04 :)
    – MTP1984
    Feb 24, 2016 at 10:23
  • Sorry, but warming up your computer might have helped whatever was wrong with your machine, but this is in no way related to this issue. My machine is plenty hot most of the time, and still suffers from this problem until I used the accepted solution.
    – Ajax
    Jul 27, 2016 at 6:13
  • Hilarious. No pun intended. Freezing mechanical hard drives is a thing aswel. Apr 15, 2020 at 16:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.