0

The Docky/Plank icons on the homonym docks let the user edit the settings more quickly than modifying the configuration file, I unpinned them and now I don't know how to pin them on again.

  • Ok, I found the "solution" myself: I simply created the "docky.dockitem" and "plank.dockitem" files in ~/.config/plank/dock1/launchers again. – Sypnos Feb 10 '15 at 15:20
8

In version 0.11.1 the solutions listed here no longer work because Plank has migrated to GSettings for storing its settings - at a long last. I've been nagging Rico to do that since forever.

To enable/disable the plank icon in 0.11.1 and later, open dconf-editor (if it's not installed, run sudo apt-get install dconf-editor) and navigate to net.launchpad.plank.docks.dock1. You will see a list of settings for the dock in there, including a show-dock-item checkbox. Check it to show the plank item in dock.

  • dconf write /net/launchpad/plank/docks/dock1/show-dock-item [true/false] – Martín Coll Jul 13 '18 at 19:04
3

This is what I had to do,

  • Navigate to /home/shashwat/.config/plank/dock1
  • Open the file settings
  • Find these lines,
    #Whether to show the item for the dock itself.
    ShowDockItem=false
  • Change ShowDockItem to true and save file.
  • 1
    And no, doesn't works with the last version: 0.11.1-2 in Antergos. I can't drag the icons and change his order, any news for this? – SalahAdDin May 14 '16 at 7:29
  • 1
    @SalahAdDin version 0.11.1 uses dconf to store settings, see askubuntu.com/a/772316/4770 – Shnatsel May 14 '16 at 13:40
  • Ok, yes, but, if you can't report it, in this version the lock item settings ever are in true, putting false yet. – SalahAdDin May 14 '16 at 23:35
2

Simply "Ctrl + Right Click" on the plank, it will open a context menu, there you can choose "Preferences". :)

OR

Simply type this in the Terminal (Ctrl+Alt+T),

plank --preferences

Both will do the trick, if you didn't find settings in /home/USERNAME/.config/plank/dock1

1

In version 0.11.1 the solutions listed here no longer work because Plank has migrated to GSettings for storing its settings - at a long last. I've been nagging Rico to do that since forever.

To enable/disable the plank icon in 0.11.1 and later, open dconf-editor (if it's not installed, run sudo apt-get install dconf-editor) and navigate to net.launchpad.plank.docks.dock1. You will see a list of settings for the dock in there, including a show-dock-item checkbox. Check it to show the plank item in dock.

I do not understand what you mean by navigate to net.launchpad.plank.docks.dock1. I am using Ubuntu Mate

1

This is what I had to do,

  • Navigate to ~/.config/plank/dock1
  • Open the file settings
  • Find these line: ShowDockItem=false
  • Change ShowDockItem to true and save file.

works thanks.

0

NOTE:

.11.3 does not HAVE a settings file in the ~/.config/plank/dock1 area to change.

In the preferences, you can turn off 'show unpinned', but then you are not going to see any open application that is not pinned once it loses focus and have to alt-tab back to it ... which is disorienting and you can forget you are even running stuff. It then started showing up again anyway after I logged out and back in (wth?!)

How I fixed it:

  1. I opened files as root in Elementary OS with a right click.(or whatever your file manager is by the normal method)
  2. Go to /usr/share/applications and find plank.
  3. Edit it with a text editor.
  4. At the bottom, add on a blank line:

hidden=true

  1. Log out and log back in.

This forces it to not show up both in the menu and in the plank... ever. ;)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.