1

My aim is to replace nautilus with nemo from universe in ubuntu devel (currently vivid) using unity. I am close to this goal, after reading about DefaultFileManager from ubuntu help and this or this question on askubuntu.com.

So far I created .desktop files for nemo in ~/.local/share/applications:

cd ~/.local/share/applications 
for i in `ls nemo*desktop`; do echo -e "\n### $i\n"; cat $i; done

### nemo-autorun-software.desktop

[Desktop Entry]
Name=Run Software
TryExec=nemo-autorun-software
Exec=nemo-autorun-software %u
Icon=application-x-executable
NoDisplay=true
Terminal=false
StartupNotify=true
Type=Application
MimeType=x-content/unix-software;

### nemo-connect-server.desktop

[Desktop Entry]
Name=Connect to Server
TryExec=nemo-connect-server
Exec=nemo-connect-server
Icon=applications-internet
NoDisplay=true
Terminal=false
StartupNotify=true
Type=Application

### nemo-folder-handler.desktop

[Desktop Entry]
Name=Nemo File Manager
Comment=Access and organize files
Exec=nemo %U
Icon=system-file-manager
Terminal=false
NoDisplay=true
Type=Application
StartupNotify=true
Categories=GNOME;GTK;Utility;Core;
MimeType=inode/directory;application/x-gnome-saved-search;

### nemo.desktop

[Desktop Entry]
Name=Nemo File Manager
Comment=Access and organize files
Keywords=folder;manager;explore;disk;filesystem;
Exec=nemo %U
Icon=system-file-manager
Terminal=false
Type=Application
StartupNotify=true
Categories=GNOME;GTK;Utility;Core;FileManager;
Actions=Window;

[Desktop Action Window]
Name=Open a New Window
Exec=nemo

Then I set the following defaults for mime types to use nemo.desktop as suggested in here:

xdg-mime default nemo.desktop inode/directory application/x-gnome-saved-search

Additionally I set this value (as in DefaultFileManager about mcterm):

xdg-mime default nemo.desktop x-directory/normal

After logout and login, clicking on desktop folder icons still starts nautilus. Despite that, the command xdg-open $HOME opens the folder with nemo (see here).

I do not want to ...

a) ... handle desktop icons with nemo, since there exist rendering problems (see here for example).

b) ... uninstall nautilus (rendering problems with nemo) or rename binaries as suggested in here.

c) ... use a different window manager than unity (so it is not a duplicate of this question, since there, Gnome is used).

So again the question:

How to open folders with nemo by clicking on folder icons on the desktop handled by nautilus or directly within nautilus?

  • I believe the best you'll get in this scenario is the option to open the folder with nemo via the context menu. A left click will just use the default for dir.'s which on the Desktop or within nautilus itself is obviously nautilus. – doug Feb 9 '15 at 17:57
  • Unfortunately, there is no 'open with' option. Is this what you meant? Also in preferences, you cannot select default application as for text/plain etc... – setempler Feb 9 '15 at 19:02
  • It was removed in nautilus quite some time ago & ubuntu has declined to return even though the patch is just 1 line in an area that rarely changes. I eventually gave up on my bug report & just provide patched builds. Generally don't do during dev because I have to keep rebuilding but someone inquired the other day so did so for vivid. There has been an update to nautilus since then so just uploaded another build, should be published within the hr. If inclined look here - launchpad.net/~mc3man/+archive/ubuntu/nauty-open – doug Feb 9 '15 at 21:33
  • Thanks, I tried your version of nautilus. It worked so far. In 'Open With'>'Other Application' it is not possible to set a default, which would solve my problem. Is there a way to implement it? – setempler Feb 11 '15 at 9:26
  • No, that's what I meant by 'the best..' The ability to changes default for inode/directory was removed from nautilus quite some time ago & rightly so, it was only useful for causing problems. – doug Feb 11 '15 at 16:47
0

One can use the modified version of nemo (ppa here) for unity from webupd8.org (instructions here).

I followed the instructions, but did not install but upgrade only:

sudo add-apt-repository ppa:webupd8team/nemo
sudo sed -i 's/vivid/devel/' /etc/apt/sources.list.d/webupd8team-ubuntu-nemo-vivid.list
sudo apt-get update && sudo apt-get upgrade

Then I changed gsettings to replace nautilus with nemo as desktop handler:

gsettings set org.gnome.desktop.background draw-background false
gsettings set org.gnome.desktop.background show-desktop-icons false
gsettings set org.nemo.desktop show-desktop-icons true

Logout, login, and nemo handles desktop without rendering problems.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.