7

I am running Xubuntu 14.10 on a brand new machine. Fresh install and everything. I have a GeForce 610 video card with an HDMI out, and the PC is hooked up to a TV. The video transmits fine - but the audio does not. There is no audio at all. When you go to the volume control, it says that the GF119 HDMI Audio Controller is there, and shows the volume from the screen - but the port (HDMI / DisplayPort) is "unplugged". Obviously, since I can see the video, that is not true.

The weird thing is that, at one point while setting up the computer, I did manage to get sound. However, I rebooted later (adjusted some video settings) and the sound was gone.

I realize that this might have very little to do with ubuntu, and is probably an NVIDIA problem, but I am at my wits end here (I'm been fighting this thing for over a year, and now this new solution is SO CLOSE, and yet so far).

Other info:

  • I am using the proprietary driver for NVIDIA (no other driver seemed to transmit the video correctly).
  • Going through the NVIDIA configuration, there are no configurable options for the audio output that I have found.
  • NVIDIA driver version is 331.113
  • When updating my video card settings (which is what prompted the reboot), I had to save a xorg.conf file to preserve the settings over the reboot. This was generated by the NVIDIA program

Again, at one point during the setup, I did indeed get sound over the HDMI to the TV. At that time, it registered that the HDMI audio output was not unplugged. However, whatever triggered that wonderful success is not there anymore, and I am having the damnedest time fixing it.

Any articles I have found on the topic are 2 years old, and even after trying their solutions, they don't seem to work for me.

6

As it turns out, I am a dork. When in the audio settings, in the farthest-right tab of profiles, the profile for the HDMI was set to "unplugged". Why that is even an option, who knows. However, I changed it to the "plugged in" profile, and everything worked fine.

  • 1
    You are not a dork, the setting is a dork. This helped me, thanks. – user78274 Nov 14 '15 at 22:36
  • 5
    Hmm. All I have are "unplugged" profiles. ubu 15.10. – Don Branson May 26 '16 at 1:59
  • 1
    me too, having all unplugged profiles – rancho Jun 18 '16 at 15:25
  • Note to others - keep trying different profiles in the Configuration tab - I had to use 'Analog Speaker' to ultimately get it to work. – FourOhFour May 11 '18 at 18:41
0

In my case, xrandr displayed: HDMI-1 disconnected (normal left inverted right x axis y axis) HDMI-2 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 509mm x 286mm

...and the default sound output was HDMI-1, when I changed it to HDMI-2 the sound worked fine.

protected by Community May 30 '15 at 7:08

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.