2

I have added symbolic links pointing to libnpjp2.so of jdk1.8.0_25 (in jdk1.8.0_25/jre/lib/i386/) to the following locations:

  • /usr/lib/mozilla/plugins
  • /usr/lib/firefox-extensions/plugins
  • /home/(myusername)/.mozilla/plugins

With no success. Going to about:plugins and about:extensions shows that firefox is not seeing the links, or not using them successfully. I have restarted both firefox and my computer and the problem persists.

The same symbolic link worked fine prior to firefox requesting permission to update. After finishing updating and restarting, the plugin is not recognized or used. I am currently using the 32-bit plugin from 32-bit Java with 32-bit firefox on a 32-bit lubuntu installation. Current firefox version is 35.0.1, I am unsure as to which version I was using before the update, but I would assume the update immediately preceding it.

I cannot see any reason for it to not work, yet it doesn't. Why is this (if you can think of any more needed information, ask away and I will update the post)?

UPDATE: Found solution - as per https://support.mozilla.org/en-US/kb/use-java-plugin-to-view-interactive-content it can be fixed by removing pluginreg.dat in the profile folder (instructions for locating this can be found at the site).

1

Delete pluginreg.dat in the profile folder. Instructions for finding this folder can be found at https://support.mozilla.org/en-US/kb/use-java-plugin-to-view-interactive-content.

  • OK, but which directory is the correct one to create the symlink in? I tried all three, deleted pluginreg.dat, and Firefox 50 still doesn't see the Java 32-bit plugin I've symlinked. (I need 32-bit for my shitty bank's online check deposit applet that accesses the scanner.) – Dan Dascalescu Jan 23 '17 at 4:52

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.