I want to build the Empathy in Ubuntu 11.04. When I follow the build process,


The shell said to me that

libtoolize: copying file `m4/lt~obsolete.m4'
checking for autoconf >= 2.53...
testing autoconf2.50... not found.
testing autoconf... found 2.67
checking for automake >= 1.9...
testing automake-1.11... found 1.11.1
checking for libtool >= 1.5...
testing libtoolize... found 2.2.6b
checking for glib-gettext >= 2.2.0...
testing glib-gettextize... not found.
***Error***: You must have glib-gettext >= 2.2.0 installed
to build Empathy.  Download the appropriate package for
from your distribution or get the source tarball at

But when I cannot find the way to install glib. What should I do to install that in ubuntu 11?

  • Why do you ask for gnome-common that is not even mentioned in that output?
    – enzotib
    Commented Aug 23, 2011 at 11:05
  • @enzotib I revised the title to match what is really being asked.
    – Thomas Ward
    Commented Aug 23, 2011 at 11:34

3 Answers 3


You need libglib2.0-dev for glib-gettext. You can install it with

sudo apt-get install libglib2.0-dev
  • 3
    I'm allergic to apt-get :). So, I used sudo apt install libglib2.0-dev instead. Commented Dec 22, 2020 at 7:01
  • apt-get is the older "outdated" version
    – Nuno Lopes
    Commented Feb 28 at 17:20

you also need to install libgtk2.0-dev in order to install glib completely (glib is a part of : libgtk2.0-dev)

sudo apt-get install libgtk2.0-dev

see this link for more explaination: installing gtk and glib

  • 1
    This one solved my problem. I installed libglib2.0-dev before but was encountering problems installing gobject-introspection. Tried to install glib manually but didn't help. Commented Nov 2, 2017 at 8:21

I recommend you search for available ppa's if you want to just checkout the newer empathy than you have. I think this ppa is the best bet Or just do this

sudo add-apt-repository ppa:telepathy/ppa

Or if you need to build it.

sudo apt-get build-dep empathy

which will install all the dependencies required to build empathy from source.

  • 1
    Need to say that build-dep will install al required dependencies for building the repo version of empathy. The newer version could require other packages too, or newer versions of some package.
    – enzotib
    Commented Aug 23, 2011 at 11:07
  • @sagarchalise when I use the second command to build, shell said .Reading package lists... Done Building dependency tree Reading state information... Done E: Build-Depends dependency for empathy cannot be satisfied because no available versions of package libnotify-dev can satisfy version requirements
    – user8260
    Commented Aug 23, 2011 at 13:59

You must log in to answer this question.