I'm in confusion because I'm not getting my eclipse even after installing. I downloaded .tar.gz file of eclipse. Then I generated .deb file using command: sudo alien -d eclipse.tar.gz

Then I tried to install it using command:

sudo dpkg -i ./eclipse_1-2_all.deb

It didn't give me any error and seemed to have worked but there's no eclipse application in dash home. What should I do? Kindly suggest.

  • 1
    Why not use Ubuntu Software Center? This is Ubuntu, there is no need to download. – user68186 Feb 8 '15 at 14:32
  • AFAIK you are supposed to extract the zip file and run the installer. – Registered User Feb 8 '15 at 14:33
  • What is the output of which eclipse? – terdon Feb 8 '15 at 14:36
  • 2
    Not sure what you did and why, but the downloaded version of eclipse usually creates a .desktop file on first run. In other words, before that, you will not find it in Dash. If your executable is not in $PATH, you can find it by looking inside your .deb file. Creating a .deb. file of it seems a needless step however. – Jacob Vlijm Feb 8 '15 at 14:41
  • 1
    Well, you got some suggestions. Did you try any of it? You didn't answer the request for information, what more would you like us to do? – Jacob Vlijm Feb 9 '15 at 20:49

I've finally got the solution after a lot of time. I've been missing jdk in my ubuntu that's why .sh files were unable to be run. I got this idea while installing pycharm but I had to install eclipse from synaptic package manager. Thanks to all for your suggestions.

Not the answer you're looking for? Browse other questions tagged or ask your own question.