0

I am recently change from Kubuntu to Xubuntu. I think some files might be deleted. I am trying to install Vlc Player and other .deb packages it throws following error. Please help

Error:

root@Aravinth:/home/aravinthan/Softwares/Players# sudo dpkg -i vlc-media-player-2-    1-4-es-en-br-fr-de-it-cn-ubu.deb 
(Reading database ... 312909 files and directories currently installed.)
Preparing to unpack vlc-media-player-2-1-4-es-en-br-fr-de-it-cn-ubu.deb ...
Unpacking vlc (2.1.4-1) over (2.1.4-1) ...
dpkg: dependency problems prevent configuration of vlc:
vlc depends on vlc-nox (= 2.1.4-1).
vlc depends on libtar0.
vlc depends on libvlccore7 (>= 2.1.0).

dpkg: error processing package vlc (--install):
dependency problems - leaving unconfigured
Processing triggers for mime-support (3.55ubuntu1.1) ...
Processing triggers for bamfdaemon (0.5.1+14.10.20140925-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Processing triggers for desktop-file-utils (0.22-1ubuntu2) ...
Processing triggers for gnome-menus (3.10.1-0ubuntu2) ...
Processing triggers for man-db (2.7.0.2-2) ...
Errors were encountered while processing:
vlc
root@Aravinth:/home/aravinthan/Softwares/Players# 

and i am trying to install vlc-nox and it requires these following lib. what can i do?

root@Aravinth:/home/aravinthan/Softwares/Players# sudo dpkg -i vlc-nox_2.1.4-1_amd64.deb 
Selecting previously unselected package vlc-nox.
(Reading database ... 312909 files and directories currently installed.)
Preparing to unpack vlc-nox_2.1.4-1_amd64.deb ...
Unpacking vlc-nox (2.1.4-1) ...
dpkg: dependency problems prevent configuration of vlc-nox:
 vlc-nox depends on liba52-0.7.4.
 vlc-nox depends on libass4 (>= 0.9.7); however:
  Package libass4:amd64 is not installed.
 vlc-nox depends on libavcodec54 (>= 6:9.1-1) | libavcodec-extra-54 (>= 6:9.13); however:
  Package libavcodec54:amd64 is not installed.
  Package libavcodec-extra-54 is not installed.
 vlc-nox depends on libavformat54 (>= 6:9.1-1); however:
  Package libavformat54:amd64 is not installed.
 vlc-nox depends on libavutil52 (>= 6:9.1-1); however:
  Package libavutil52:amd64 is not installed.
 vlc-nox depends on libbasicusageenvironment0; however:
 vlc-nox depends on libcddb2; however:
 vlc-nox depends on libgnutls28 (>= 3.2.10-0); however:
  Package libgnutls28:amd64 is not installed.
 vlc-nox depends on libgroupsock1; however:
 vlc-nox depends on libkate1 (>= 0.3.0); however:
 vlc-nox depends on liblircclient0; however:
 vlc-nox depends on liblivemedia23; however:
 vlc-nox depends on libmodplug1; however:
 vlc-nox depends on libpostpro
dpkg: error processing package vlc-nox (--install):
 dependency problems - leaving unconfigured
Processing triggers for man-db (2.7.0.2-2) ...
Errors were encountered while processing:
 vlc-nox
root@Aravinth:/home/aravinthan/Softwares/Players# 

what's my Problem?

marked as duplicate by muru, Fabby, Eric Carvalho, Elder Geek, v2r Feb 9 '15 at 11:42

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • i am tring to use apt-get -f install the following dpkg: error processing archive /var/cache/apt/archives/libvdpau1_0.7-2_i386.deb (--unpack): trying to overwrite shared '/etc/vdpau_wrapper.cfg', which is different from other instances of package libvdpau1:i386 Errors were encountered while processing: /var/cache/apt/archives/libvdpau1_0.7-2_i386.deb E: Sub-process /usr/bin/dpkg returned an error code (1) – Aravinthan K Feb 8 '15 at 13:47
  • I am trying with gdebi these error "This package is uninstallable Dependency is not satisfiable: vlc-nox (= 2.1.4-1)" – Aravinthan K Feb 8 '15 at 14:03
  • Wait, why are you installing Vlc using a deb file? It is available in the Software Center. – muru Feb 8 '15 at 14:07
  • same Problem in Software center please view @ s26.postimg.org/qtuvk32xl/VLC_PRoblem.png – Aravinthan K Feb 8 '15 at 14:15
  • Of course the same problem will come. The dpkg command messed things up. Try removing vlc first: sudo apt-get remove vlc-media-player. – muru Feb 8 '15 at 14:16
-1

Maybe you need gdebi, it can help you auto-install what the dependences when you install .deb.

First, you should install it sudo apt-get install gdebi

then, you can sudo gdebi xx.deb

  • Nobody needs GDebi. The Software Centre can handle deb files and dependencies. – muru Feb 8 '15 at 13:49
  • These error root@Aravinth:/home/aravinthan/Softwares/Players# sudo apt-get install gdebi Reading package lists... Done Building dependency tree Reading state information... Done You might want to run 'apt-get -f install' to correct these: The following packages have unmet dependencies: gdebi : Depends: gdebi-core (= 0.9.5.4) but it is not going to be installed vdpau-va-driver:i386 : Depends: libvdpau1:i386 (>= 0.2) but it is not going to be installed E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution). – Aravinthan K Feb 8 '15 at 13:51
  • sorry, I never use Software Center to install software, so I don't know it is so powerful.Maybe I can try it.Thank you!! – wozhapen Feb 8 '15 at 13:53
  • Its works. I just remove that vdpau-va-driver:i386 from etc folder – Aravinthan K Feb 8 '15 at 13:56
  • I am trying with gdebi these error "This package is uninstallable Dependency is not satisfiable: vlc-nox (= 2.1.4-1)" – Aravinthan K Feb 8 '15 at 14:02

Not the answer you're looking for? Browse other questions tagged or ask your own question.