19

The names of my folders and the menus are not displayed correctly (even the tabs names in firefox). A lot of letters are missing. When cross over with the mouse pointer, part of them are correctly displayed. Contrary, the content of askubuntu site, for example, is displayed correct. It does not always happens, usually a restart solve the problems for a while. I have Ubuntu 14.04. I don't know how to tag this question, so I'll mark it as display related, even though is not really this.

enter image description here

9

There seems to be a (bad) fix for this problem as described here

The problem seems not to appear by using the old UXA hardware acceleration for for the Intel graphic cards.

Edit the following section of the /etc/X11/xorg.conf file such that AccelMethod is set to "uxa" or create the file if it does not yet exist:

Section "Device"
   Identifier  "Intel Graphics"
   Driver      "intel"
   Option      "AccelMethod"  "uxa"
EndSection

Reboot or restart X.

The problem went away for me, but I only restarted a couple of times since I changed the file so it might still come back. Also, note that UXA acceleration is considerably slower!

edit: There is a fix for this in the repository by now. If you still experience this issue you either did not update your system for a while or it has a different cause and I suggest filing a new bug.

| improve this answer | |
  • Why not use the officially supported 4.2-lts kernel? Because apparently this didn't happen before Linux 4.4. – NoBugs Mar 17 '17 at 2:36
5

As mentioned in the comment above regarding the missing letters link, I have this specific problem (on 16.04, usually after returning from suspend), and so far, using unity/gnome tweak and switching fonts to greyscale anti-aliasing is working: https://askubuntu.com/a/633435/172307

| improve this answer | |
  • While this link may answer the question, it is better to include the essential parts of the answer here and provide the link for reference. Link-only answers can become invalid if the linked page changes. - From Review – Pilot6 Jun 1 '16 at 8:39
  • Agree with @Pilot6, but he's linking internally. There is a wealth of information in that thread. – earthmeLon Jun 1 '16 at 20:01
3

This fixed the problem for me, Updated and Optimized Open Graphics Drivers

https://launchpad.net/~oibaf/+archive/ubuntu/graphics-drivers

sudo add-apt-repository ppa:oibaf/graphics-drivers
sudo apt-get update
| improve this answer | |
  • Drivers do not support Ubuntu 14.04 LTS/ – Gaurav Agarwal Jan 20 '18 at 14:20
2

I had the same issue. I fixed it on my Chromebook Pixel LS (booting into 14.04 w/ Gnome DE) by not using any Ubuntu family fonts. YMMV

| improve this answer | |
  • 1
    I've had this issue for years on my Dell Latitude E5530 on Ubuntu 14.04 LTS and 16.04 LTS nearly every time I unplug from external monitors. Changing the font from the default Ubuntu fonts has been the first thing to work for me. – Dump Cake Feb 2 '17 at 19:10
  • That's a bad "solution" as Ubuntu is the font everyone will know and love if they are used to Ubuntu default. Why not use the proper Linux 4.2? – NoBugs Jul 16 '17 at 5:20
2

According to https://bbs.archlinux.org/viewtopic.php?pid=1633207#p1633207 this bug is caused by some unindentified change in Linux kernel version 4.3 or 4.4. Workaround is to use kernel version 4.2 or older, or update to version 4.6 or later. I don't know if kernel version 3.x has this bug.

For Ubuntu 16.04 the fix is simple:

sudo apt install linux-generic-hwe-16.04

or (to get better performance as a side-effect)

sudo apt install linux-lowlatency-hwe-16.04

Some hardware may not be compatible with lowlatency kernel so you need to test if your system works.

Installing unofficial development drivers from https://launchpad.net/~paulo-miguel-dias/+archive/ubuntu/mesa or https://launchpad.net/~oibaf/+archive/ubuntu/graphics-drivers may also fix the issue.

| improve this answer | |
  • Since it used to work, and doesn't with latest linux kernel 4.4 on 14.04, that makes sense. On 14.04 you can run sudo apt-get install linux-image-generic-lts-wily, and sudo apt-get remove linux-image-generic-lts-xenial – NoBugs Mar 17 '17 at 2:25
  • - and afterward you will probably have to use Synaptic to search for linux-generic and remove ONLY the 4.4.x kernels. – NoBugs Mar 17 '17 at 2:38
  • It's getting annoying that the updater keeps asking you to upgrade the new kernel... then it's on 4.4. I guess we have to wait for a 4.6 update for 14.04? – NoBugs Jun 29 '17 at 4:28
  • Not quite sure if compatibility is the only issue which should be considered, when installing -low-latency. Or make it the other way around, why not recommending -rt or -realtime to "get better performance as a side-effect"? Refering to UbuntuStudio RealTimeKernel you should only do this, if you really need this. From my point of view, you should elaborate more on the differences between both modes. – Murmel Oct 25 '17 at 22:45
  • Yeah, -lowlatency kernel may affect your power saving features (I have yet to see any real world data about this, though). -rt or -realtime kernels are often inferior to -low-latency because those are not based on vanilla kernel. As a result, -rt or -realtime kernels (if available at all) are usually much older kernels than -lowlatency. In my experience, unless you know better, newer kernel release is better than older kernel with RT patches. I'm personally using -lowlatency kernels in old laptops, too. – Mikko Rantalainen Oct 27 '17 at 7:22
0

I fixed this problem with a very easy solution , just go to ubuntu settings>universal access> large text turn on. log off from ubuntu or restart, log back in and again go to settings>universal access >large text and turn off. hope it helps.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.