I am new to Ubuntu but I have been trying to get my Nvidia 840m graphics drivers working correctly for months. My set up -

HP Envy 15 - i7 - 8GB - Nvidia 840m graphics

I have installed the Nvidia 340 drivers using xorg edgers and the system boots into a blank screen instead of log in. The sound plays indicating that the system cannot output to my laptop display.

I have managed to get the drivers working once off first install where they worked for around 2 weeks before reverting to the blank screen.

I also managed to get the drivers working off a recent vanilla install but they froze the system and then the blank screen at log in resumed on reboot.

I get the feeling something needs adding to the xorg config file to make the screen detectable but would have no idea if this is correct or what to add.

Any help would be appreciated and thanks in advance!

I have also tried -

The bumblebee route - the drivers through and error and would not switch.

The drivers off Nvidia website - this was a disaster of biblical proportions and let me to reinstall the OS.

Doing all the above in 14.10

************************ update ********************

It looks like the driver works fine if the lid is closed after the blank screen has appeared and the system is resumed. Very strange. It seems to load fine from resume but not from a regular boot

  • I am having the same trouble right now, also with the Nvidia 840m. Sitting here since 2 hours and I am only getting a black screen. If you look for my previous question, you'll find a similar one. I thought I fixed it, but no not working again after a few days... If someone really has a solution for this, that would be awesome. Some people even posted this bug to launchpad but it was classified as an unimportant bug.
    – Flatron
    Feb 7, 2015 at 23:18
  • Its strange that for me the Nvidia boots after resume. I hope there is a solution to this soon. I also tried the methods you tried previously earlier today.
    – Marko
    Feb 7, 2015 at 23:51
  • I tried the "resume method" not working, sadly. I think there is an error in the driver because nobody seems to get the nvidia 840m graphics card to work longer than a few weeks.
    – Flatron
    Feb 7, 2015 at 23:52
  • 1
    I seem to be getting on OK since booting the driver into life from resume. As long as I shut down with intel graphics selected it seems to be OK. There is clearly something not quite right though. I really hope we can get a solution soon. I am not sure this is the right place to get support though. Despite the name, the vast majority of issues seem to go unanswered.
    – Marko
    Feb 8, 2015 at 11:02
  • Maybe someone could summarize this whole issue and report the bug to nvidia / edgers / ubuntu. I am not sure what is the right place for this.
    – Flatron
    Feb 9, 2015 at 10:29

2 Answers 2


OK, I think I have found a solution and it would be good if others with the same problem could test.

  • Install the Nvidia 340 drivers from the Xorg edgers PPA.

  • Once the install is complete, do not reboot. Head into Prime and set the profile to Intel graphics.

-Add the following line to your Xorg.conf, under the Nvidia Screen header - Option "UseDisplayDevice" "DFP"

  • Reboot.

  • You should now have the drivers installed but be running in Intel graphics mode. This should be checked in Prime.

  • In order to use the Nvidia, set the profile in Prime and the LOG OUT. Do not reboot.

  • Important to remember, you should not reboot or shut down the machine when in Nvidia graphics profile. Intel should be reset before each shutdown / reboot.

  • Marko's answer helped. But my xorg.conf was blank so I haven't added UseDisplayDevice. And I was unable to switch to intel until I rebooted first.
    – Verd
    Feb 8, 2015 at 16:21

I had the same (or similar?) issue with Ubuntu 16.04.2 and an Asus laptop with both a GeForce 840M and an Intel card - when I installed the 375.66 driver (using "additional drivers"), Ubuntu booted to a black screen. I could still hear the startup noises so I knew it was just the display.

So I pressed ctrl-alt-f1, logged in at the command line and installed nvidia-prime. Then I ran prime-select intel and restarted with sudo reboot.

This let me boot into the GUI again and everything looked good except obviously I was using the Intel card.

So I again pressed ctrl-alt-f1 and this time ran prime-select nvidia. Then I could reboot and the GUI worked and the NVidia driver was running!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.