1

I've recently installed indicator-multiload on my laptop running Ubuntu 14.10 and noticed my CPU sits most of the time at high frequencies, even with very little load. It is an i7-4700MQ processor which should use frequencies between 800 MHz and 3.4 GHz (with Turbo Boost). Now even when load is 0-2%, the frequencies I see are usually between 2.5 and 3.1 GHz, which means the CPU is almost always Turbo Boosting.

My Ubuntu also uses significantly more power than Windows (where the CPU is often in the 0.8 - 1.8 GHz range) with little load, so I'm thinking it's not just a wrongly displayed frequency.

I haven't manually changed any setting or installed anything that should affect the CPU behaviour. Below is the content of my cpufreq and intel_pstate, which looks right to me:

$ cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_driver 
intel_pstate
$ cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_min_freq 
800000
$ cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_max_freq 
3400000
$ cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_cur_freq 
2852437

$ cat /sys/devices/system/cpu/intel_pstate/min_perf_pct 
23
$ cat /sys/devices/system/cpu/intel_pstate/max_perf_pct 
100    
$ cat /sys/devices/system/cpu/intel_pstate/no_turbo 
0

Has anyone seen this before or knows how to avoid using high frequencies for no reason?

Just to mention, I know Turbo Boost can be disabled, which would probably limit the max frequency to 2.4 GHz, but that seems like overkill, since I don't want to limit my CPU performance when I need it.

Thank you.

EDIT: The scaling governor is set to powersave:

$ cat /sys/devices/system/cpu/cpu*/cpufreq/scaling_governor
powersave
powersave
powersave
powersave
powersave
powersave
powersave
powersave

These are the frequencies:

$ cat /sys/devices/system/cpu/cpu*/cpufreq/scaling_cur_freq
2492343
2740218
2502562
2438625
2435718
2782500
2783250
2697000

Nothing is using my CPU. As I said, usage is at about 1%. If I run top, it is the only running user process:

Tasks: 266 total,   1 running, 265 sleeping,   0 stopped,   0 zombie
%Cpu(s):  1.3 us,  0.2 sy,  0.0 ni, 98.5 id
  • Your post does not provide sufficient information to answer. What is using your CPU ? run top on a terminal ;) – Panther Feb 7 '15 at 21:54
1

After more looking around, I've found two relevant issues on the kernel bugtracker that describe the same symptoms I'm experiencing. This one is marked as fixed, but this other one is new, with people reporting it's not yet fixed.

There seems to be something going on with putting the computer to sleep. The CPU runs normally, i.e. at low frequencies while idle, just after a reboot, but is stuck to high frequencies after waking up from sleep. After a fresh reboot, my frequencies looks like this (compare to what's posted in the question):

$ cat /sys/devices/system/cpu/cpu*/cpufreq/scaling_cur_freq
1588875
800062
800062
800062
928500
2112937
800250
1911750

I guess for now we just have to wait until this is fixed.

  • You could go back to the acpi-cpufreq driver until those bugzilla issues are fixed. See my previous comment for how to force the driver. – Doug Smythies Mar 5 '15 at 15:42
0

This should be a comment, but I don't have enough points yet:

Please post the output as per this example:

doug@s15:~/temp$ cat /sys/devices/system/cpu/cpu*/cpufreq/scaling_governor
powersave
powersave
powersave
powersave
powersave
powersave
powersave
powersave

A very aggressive CPU frequency Verses load curve should only occur when the scaling governor is set to performance. However, and currently, it doesn't take much load, even in powersave mode to raise the CPU frequency from the minimum pstate.

Could you edit your post to show all CPU frequencies. Example:

doug@s15:~/temp$ cat /sys/devices/system/cpu/cpu*/cpufreq/scaling_cur_freq
1627750
1627750
1627750
1627750
1627750
1627750
1627750
1627750

You could also try the acpi-cpufreq driver instead of the intel_pstate driver. Change this line in grub to do so (in this example I have a couple of other items on the line also):

GRUB_CMDLINE_LINUX_DEFAULT="ipv6.disable=1 intel_pstate=disable crashkernel=384M-:128M"

If you do try the acpi-cpufreq driver, please post back here your findings.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.