1

I can't compile ("make") anything at the moment. It all ends with the following:

as: unrecognized option '--64'

So I searched for the cause and found that

gcc -version

gave me this:

gcc (GCC) 4.1.2 20060728 (prerelease) (TIGCC 4.1.2-pre9)
Copyright (C) 2006 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

Ah, yes, I did install TIGCC at some point (it's used to cross-compile C programs for the TI calculators). I really don't need it anymore, but I can't find how I'm supposed to reconfigure gcc back to normal. I tried doing

sudo apt-get install --reinstall gcc binutils

but it doesn't change anything. I could try with --purge, but that would require me to uninstall a lot of other packages (like graphic drivers x_x). Anything simpler I should try? :)

Thanks!

UPDATE

type -a

returned two paths for gcc, one of which was the one from tigcc. I deleted that file and now gcc --version shows the correct one (4.8.2). However, I still get the same errors! :(

$ as --version
GNU assembler 2.16.1
Copyright 2005 Free Software Foundation, Inc.
This program is free software; you may redistribute it under the terms of
the GNU General Public License.  This program has absolutely no warranty.
This assembler was configured for a target of `m68k-coff'.

I have no idea what m68k-coff is/means... but I'm on a AMD x64 system! ?

  • 1
    m68k-coff is a cross compiler for win – chaskes Feb 7 '15 at 5:15
  • 1
    What does dpkg -S $(which as) say? – muru Feb 7 '15 at 5:17
  • dpkg-query: no path found matching pattern /home/USER/bin/as – comeauch Feb 7 '15 at 5:18
  • but 'which as' returns 'home/USER/bin/as' which looks suspicious to me... the gcc from TIGCC was also in there... should I just delete that as well? – comeauch Feb 7 '15 at 5:20
  • 1
    @muru so the binaries were in home, which explains why it wasn't part of the alternatives setup; but I'm still unsure about what just happened here. – chaskes Feb 7 '15 at 5:25
0

So in the quite improbable case that anyone has the same problems and doesn't mind getting rid of TIGCC, I had to delete /home/USER/bin/gcc and /home/USER/bin/as.

When issuing

$ type -a
/usr/bin/gcc
/home/USER/bin/gcc

and same thing for as.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.