1

I need to install this program rcsoccersim.

I added this PPA ppa:gnurubuntu/rubuntu which caused me to get these 1 deb http://ppa.launchpad.net/gnurubuntu/rubuntu/ubuntu saucy main 2 deb-src htp://ppa.launchpad.net/gnurubuntu/rubuntu/ubuntu saucy main

The guide I'm follwing to setup this soccer simulation tool tells me to just add the ppa run the system update and then just sudo apt-get install rcsoccersim, but it is unable to locate the package rcsoccersim

Where am I messing up?

Here's he link to the guide

I changed the gnurubuntu-rubuntu-trusty.list file

deb htp://ppa.launchpad.net/gnurubuntu/rubuntu/ubuntu quantal main

deb-src htp://ppa.launchpad.net/gnurubuntu/rubuntu/ubuntu/ quantal main

but now I'm getting this error

Reading package lists... Done Building dependency tree
Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation:

The following packages have unmet dependencies: rcsoccersim : Depends: rcssserver but it is not going to be installed Depends: rcssmonitor but it is not going to be installed Depends: rcsslogplayer but it is not going to be installed E: Unable to correct problems, you have held broken packages.

0

Note: This should be a comment, but I don't have enough points yet.

That PPA is not up to date. What version if Ubuntu are you running?

If indeed you are still running saucy, then no, it will not work because saucy is EOL (End of life). However, you could still manually download the .deb files and install them manually from here

  • Javier: Yes, there seems to be a saucy version. See the link I added. Although it isn't clear to me what is needed. – Doug Smythies Feb 7 '15 at 1:15
  • I am running mint 17.1 mate which I beleive is 14.x(Excouse me im pretty unknowledgeable about ubuntu life cycles) – Guano Feb 7 '15 at 10:38
  • If I were to download the things manually would I just go through the list and i.e download boost1.38 - 1.38.0-6jaunty6~ppa, ode - 3:0.11.1-tbb-4natty1 and so on? – Guano Feb 7 '15 at 11:12
  • No. You would just download the appropriate .deb files. Anyway, since you are running something14.X based, you are not going to overcome your dependency issues. You would need to down load the source and compile it yourself, or try to get the project owner to add an up to date PPA. – Doug Smythies Feb 7 '15 at 15:55
  • Well I went and downloaded the server and monitor from where you specified and it actually worked after fixing a few libboost dependency issues, thanks – Guano Feb 7 '15 at 18:52
0

(this should be a comment too) probably saucy :)

There is no rcsoccersim built for saucy in that PPA. Latest available package is for quantal.

Try this:

  • Change "saucy" with "quantal"
  • try again to install
  • Okay I edited my Original question and tried what you did refer to that for results – Guano Feb 7 '15 at 11:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.