15

Today I see that my "Configure VPN..." part is greyed out and I have been using several PPTP VPN connections so far and today suddenly this seems to be inactive.

I did the changes in the network manager policy, changes which are mentioned in: gray button for saving "editing VPN connection" in Ubuntu 12.04

I also tried:

sudo apt-get install network-manager-pptp
sudo network-manager restart

But the "Configure VPN..." is still greyed out so I cannot configure my existing VPNs.

I have Ubuntu 12.04 LTS. If I upgrade to 14.04, will it work again?

1
  • I have just found a way to configure through clicking System Settings -> Network and then I am able to do. Maybe my Network Manager Icon has got a problem. Feb 6 '15 at 20:12
14

Network Manager VPN support is based on a plug-in system.

The network-manager-pptp plugin is installed by default.

For OpenVPN, install these packages:

sudo apt-get install network-manager-openvpn network-manager-openvpn-gnome

Then restart your network-manager:

sudo systemctl restart network-manager

Open the Network connections program. Click on Add. Select PPTP (or OpenVPN) under the VPN section. Fill in your settings and save.

Eventually, you should be able to select a VPN config in the previously greyed out zone.

1
  • Restarting the network-manager was the key.
    – dkantowitz
    Aug 28 '19 at 23:23
13

I'm hitting the same problem on 2 different 12.04 desktop machines. I'm pretty sure the problem got introduced with the following update that came in on 2/2/2015

https://launchpad.net/ubuntu/precise/+source/network-manager-applet

BTW, you can still access the configure side of the VPN by running the "nm-connection-editor" from terminal session.

I don't know why they killed the applet selections for "Configure" and "Disconnect" VPN in the latest update. The change log didn't say anything about that https://launchpad.net/ubuntu/precise/+source/network-manager-applet/+changelog

3
  • Thanks, the hint about running nm-connection-edito on commandline is a real life saver!
    – kris
    Mar 16 '15 at 19:14
  • I'd also like to thank for that hint. The good news is that this issue has been fixed too through one of the latest updates. Regards Mar 26 '15 at 15:02
  • 20.04 desktop have the exact same problem. nm-connection-editor works!
    – Avec
    Oct 14 '20 at 11:29

Not the answer you're looking for? Browse other questions tagged or ask your own question.