1

I use http://onlineclock.net/ in order to wake up in the mornings. It is absolutely vital to me that this site work correctly. My phone alarm simply does not wake me up. If this site does not work correctly, I will miss my morning class, which is extremely important to me.

On two different occasions, now, however (though, fortunately neither time on a tuesday or a thursday, when I have this class), when Online Alarm Clock has redirected to its Alarm page, the alarm has not gone off. Instead, a message is displayed at the top of the page, saying, "Firefox has prevented the outdated plugin Adobe Flash from running."

Both times, I happened to wake up naturally within a half hour after the alarm was supposed to go off, noticed this message, and updated my Adobe Flash Player, fixing the issue temporarily. But now that this has happened on two different occasions, I absolutely cannot allow it to happen again. I need a permanent solution.

I notice that, on the message bar, there is an option to force Firefox to run the plugin anyway, despite that it is outdated. However, this is only a one-time thing. What I need is for this to be permanent (at least for this particular website).

How do I make Firefox always run Adobe Flash, even when it is outdated?

Specs – I am on a 64-bit laptop, running Ubuntu 14.04.

  • Your version of Flash-Plugin had some security related bugs which where activly used to hack computers. That's why firefox blocked it. Now there is a updated version. Install your updates and you will be able to use flash again. – MadMike Feb 6 '15 at 13:31
1

I don't think forcing an insecure version of Flash is really the answer you want. Firefox is disabling it for a very good reason: Your alarm might not go off at all if somebody hacks your computer through Flash and encrypts your documents for ransom.

Why not install Alarm Clock or use something like Evolution's calendar and alarm functions? Both will work without Flash. Both will work without an internet connection... And there must be at least a hundred more alternatives. Keeping time is a very old problem.

As a side-note, you might want to submit a bug report to onlineclock.net to suggest they stop requiring Flash. You can play Alarm noises and videos without it and it's very easy to have them fall-back to something if Flash isn't installed.

  • I didn't realize it was a hacking issue. If that's the case, then I'll definitely take your advice. The alarm clock applet is nice. (I wish I could customize how long the "snooze" option delays the alarm for, though. 9 minutes is a little long.) – Elen Sila Feb 6 '15 at 15:04
2

If you want, you can disable the blocklist using about:config:

extensions.blocklist.enabled false

or using prefs.js:

user_pref('extensions.blocklist.enabled', false);
0

The site OnlineClock.net also has a mobile version that works without Flash. Try using it, instead of the main clock:

http://m.onlineclock.net

0

I'm very pleased to announce that we have now switched to using HTML5 alarm sounds for our website!

So any problems you encountered earlier with Flash should now be solved. :)

We've been wanting to make this change for quite some time...but recent security vulnerabilities in Flash convinced us to finally switch to using HTML5 alarms as soon as possible.

This update just makes sense, for both security and performance reasons.

Thanks for using our site!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.