A while back, I bought a Lenovo Yoga 2 11 (Model 20332), and promptly set it up to dual boot ubuntu. So far it's been a fantastic machine, however there's one thing that keeps me rebooting into windows: the clickpad.

The issue here lies in click-and-drag. The soft buttons on the pad worked, however they registered as part of the touch zone, hindering my ability to click and drag. I looking into it and followed the suggestions on this post ( Disable Mouse Movement in Tap Zones on Synaptics Trackpad ), using synclient to adjust the bottom edge of the touch zone.

This worked... sort of. It did disable the cursor movement in the touch zone, however, I still cannot move the cursor while my thumb is in this zone. So it moved me closer to a solution, but still not quite there.

Next, I followed the suggestions of this post ( Can't hold left button on touchpad and drag in 12.04 and no right click ), creating a xorg configuration file for the clickpad, even though I was not experiencing the right click issue. Again, this helped, as I can now click and drag... sometimes. It's very quirky with the way it works. If I move the cursor into position with my index finger, keep that finger on the clickpad, and then left click with my thumb, I can USUALLY click and drag. This comes with some exceptions. If the item is already selected, it wont budge.

So again, I'm closer, but not there yet. Also there is still another issue. When I use my click pad, I habitually keep my thumb on the left click zone. When I do this in ubuntu, my cursor does not move, even though I have that region set as a dead zone with synclient.

  • Did you solve your issue? I'm having a similar issue on an Acer model. – Michael Krupp Oct 26 '15 at 23:15
  • Hi, I have similar problem on Lenoto Thinkpad L450. It started after upgrade to Ubuntu 17.10. I did not fing solution so far. So I use button above touchpad (the buttons for trackpoint) when I need to click and drag. If I left click directly on touchpad area it sometimes work and sometimes not and sometimes it work for a short movement, then it stops dragging. – user241281 Mar 6 at 18:56

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.