0

A GTK2 theme, expressed in a gtkrc file, worked fine in Ubuntu 10.04 and 12.04 but part of it, shown here:

# Base style for all GTK widgets.
style "default"
{
    fg[NORMAL]             = "#000000"
    fg[ACTIVE]             = "#000000"
    fg[PRELIGHT]           = "#000000"
    fg[INSENSITIVE]        = "#808080"
    bg[NORMAL]             = "#C0C0C0"
    bg[ACTIVE]             = "#C0C0C0"
    bg[PRELIGHT]           = "#C0C0C0"
    bg[INSENSITIVE]        = "#C0C0C0"
}
class "GtkWidget" style "default"

is not working in Ubuntu 14.04 with the Unity desktop. The background specifications above, which all specify a light gray, are being ignored for many widgets, whose backgrounds are coming out a very light off-white instead. The foreground specifications are also being ignored for radio buttons. Other parts of the gtkrc file are working and are very different from default, so it is clear that this is not just a case of the whole gtkrc file being missed.

How can I re-establish these settings for a GTK2 application on Ubuntu 14.04?

0

I've now found a way to correct this. It's brute force but it works. I changed the name of the "themes" folder under /usr/shared to "themes_". The result is that all pre-installed themes are hidden from the system and our GTK theme again works.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.