0

I'm using Gnome 3, and I'm having problems with my wifi since yesterday.

I can connect to wireless router, but I can't open any page, like there's no connection.

If I connect directly to modem, using LAN, it's working.

I did reset on my wifi, tried to change channel, but with no luck, it's stil not working.

If I run iwconfig this is output

eth0      no wireless extensions.

lo        no wireless extensions.

wlan0     IEEE 802.11bgn  ESSID:"mreza"  
      Mode:Managed  Frequency:2.437 GHz  Access Point: E8:94:F6:66:CE:3E   
      Bit Rate=150 Mb/s   Tx-Power=16 dBm   
      Retry  long limit:7   RTS thr:off   Fragment thr:off
      Power Management:off
      Link Quality=62/70  Signal level=-48 dBm  
      Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
      Tx excessive retries:0  Invalid misc:81   Missed beacon:0

If I run route -n, I get this:

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         188.2.100.1     0.0.0.0         UG    0      0        0 eth0
188.2.100.0     0.0.0.0         255.255.252.0   U     1      0        0 eth0
192.168.0.0     0.0.0.0         255.255.255.0   U     9      0        0 wlan0

Does anyone have an idea, what could be wrong?

1

That 188.2.100.* address is weird and wrong. It looks like you configured eth0 to have a fixed address and default route, so the one your wireless router is setting is not taking effect (see the network route for wlan0 is OK, but there's no default route so that's why you can't access any sites). Check either in network manager -> edit connections or in the /etc/network/interfaces file.

Also, these settings don't change magically by themselves, so try to remember if you changed them at some point by hand and where you did this.

3
  • thanks for answer, but I'm a noob for this, how can I change it? My laptop works on other wifis, just on my own, it doesn't work.This is output of my interfaces file # interfaces(5) file used by ifup(8) and ifdown(8) auto lo iface lo inet loopback – Ned Feb 6 '15 at 20:22
  • Is it possible your router is misconfigured, then? if it works on other wifis it looks like your router may be the problem. Do other computers work well on your home wifi? I don't think you need to change anything on the Ubuntu side, your interfaces file looks OK and you say it works in other networks so you should be OK. – roadmr Feb 6 '15 at 20:25
  • I didn't check other computers on my wifi, but my mobile phone doesn't work either. Yes, in that case, it looks like it's the router itself. I tried to reset it to factory defaults, but that didn't help. – Ned Feb 6 '15 at 20:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.