1

So I just made a fresh install of Windows 8.1 and then Ubuntu 14.04.1. The problem is, that I can't make GRUB as the main boot option, it is not listed in BIOS so my computer just loads into Windows. I can, however access it through the boot menu (pressing F12).

Log from boot-repair

I did the bcdedit command but it didn't do anything.

I have an Acer Aspire VN7-591g laptop if it helps to know.

2

Do not know how your got grub legacy installed to MBR, but you only have UEFI boot and data in MBR will never be used.

Many vendors now modify UEFI to only boot Windows by description. So ubuntu entry does not work. But UEFI also boots hard drive entry as /EFI/Boot/bootx64.efi. So we copy grub into /EFI/Boot and rename it ot bootx64.efi and system will boot from hard drive entry.

From live installer mount the efi partition on hard drive Mount efi partition. check which partition is FAT32 with boot flag. Often sda1 or sda2 but varies.

sudo mount /dev/sda1 /mnt

mkdir only if not already existing, your have this but others may not:

sudo mkdir /mnt/EFI/Boot
sudo cp /mnt/EFI/ubuntu/* /mnt/EFI/Boot

If new folder created, the bootx64.efi will not exist, skip this command

sudo mv /mnt/EFI/Boot/bootx64.efi /mnt/EFI/Boot/bootx64.efi.backup

make grub be hard drive boot entry in UEFI. If not existing, may have to update UEFI also with efibootmgr.

sudo mv /mnt/EFI/Boot/grubx64.efi /mnt/EFI/Boot/bootx64.efi 

Other work arounds:

Dual boot Win 8 / Ubuntu loads only Win

windows 8.1 changes boot order

How do I get my HP laptop to boot into grub from my new efi file?

  • Thank you, I didn't try it but it seems very similar to what I have done. Firstly I didn't mount the sda1, editing in /boot worked fine. I also had a different folder scheme instead of EFI/Boot in had to work with EFI/Microsoft/Boot. I also didn't have to move the ubuntu contents, it was enough to just hide the bootmgfw.efi file in Microsoft/Boot. Please respond if I did anything harmful. – Jaka Feb 5 '15 at 19:19
  • New problem... now I don't have an windows option in grub meaning I cant access it at all. – Jaka Feb 5 '15 at 19:26
  • Microsoft requires the bootmgfw.efi file to boot. Boot-Repair used to rename as you have done, but does not now. When you rename bootmfgw.efi, you can only boot Windows from grub menu and must add an entry to the renamed/backup of bootmfgw.efi. And every Windows update will overwrite the grub copy with a new Windows bootmfgw.efi and you have to recopy again. Much better to keep Windows alone and edit /EFI/Boot folder.b Standard os-prober finds bootmfgw.efi to boot Windows but that then must loops back to grub. – oldfred Feb 5 '15 at 21:20
  • I later tried to change the bootx64.efi but it didn't work. And yes, I added an entry to grub so Windows shows up. – Jaka Feb 5 '15 at 21:38
  • 1
    Files look correct, but with the renaming not sure if they are your correct files. If bootmgfw.efi is the correct Windows file, you should be able to directly boot Windows from UEFI boot menu or one time boot key. And if grub or shim correctly copied to bootx64.efi then the hard drive entry in UEFI boot menu or one time boot key should boot to grub menu. – oldfred Feb 7 '15 at 15:50
0

Your laptop has two hard drives, one mechanical and one SSD. Your probably have the two operating systems installed on different drives that's why accessing the BIOS boot menu via F12 works. You have to change your boot priority in your BIOS settings to make it boot into grub permanently. Usually by pressing delete or esc at boot and change the boot order of the drives.

  • It's an SSHD drive, so that can't be it. And I don't have an ubuntu option in boot priority settings. – Jaka Feb 5 '15 at 17:09
  • You wouldn't see that in the BIOS. All the BIOS cares about is disks. So whichever disk you chose in the F12 boot menu is the disk you want to boot off of first. Set that in the boot priority in the BIOS. – vitz3 Feb 5 '15 at 17:15
  • The BIOS boot options doesn't have an ubuntu option. There is only a HDD (which is first), a windows boot manager and some USB and network options. – Jaka Feb 5 '15 at 17:32
  • This page here forum.notebookreview.com/threads/… mentions turning off secure boot and into legacy mode, perhaps that might be a solution for you. There might be implications that go along with that however though, be careful. It sounds like a matter of just booting off the drive/partition you installed Ubuntu and Grub on. – vitz3 Feb 5 '15 at 17:50
  • Is switching to legacy safe? I did however solve this using a cheat. I just hid the windows loader by moving it to another location. So the only option left in boot is grub. I would still be very happy if a better solution is found. – Jaka Feb 5 '15 at 19:04
0

I had a similar problem with win7 and, after a while searching, found a couple of sites which advocated shrinking the partition in Windows before installing Ubuntu. In windows, I deleted the ubuntu partition then recreated it and went from there, Now have a perfectly working dual boot!

This link takes you through the steps, there are a few others around in a similar vein.

  • I think I did it prety much like this. Before I installed ubuntu I shrunk the windows partition to 300gb, added a new partition for joint files and left 120gb free for the later ubuntu install. – Jaka Feb 5 '15 at 17:15
  • Is your system UEFI? – Suici Doga Mar 22 '16 at 3:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.