0

I'm on Ubuntu 14.04 LTS (workstation), and it's like Firefox is very slow (compared to the same on an old windows machine... sorry again for the reference, but I thought it would be as fast or faster than on windows). I haven't installed any add-ons or try to tune up by myself by the time.

Firefox is the 35.0.1 and thought it was slow on a Ubuntu 14.04 Server too. Is it something normal on Ubuntu?

Do I have to modify some settings on Firefox or Ubuntu to tune up this?

  • This question is unfortunately too broad to answer as is. I can tell you, that I do not have problems on my own machine, but that doesn't help you. – meskobalazs Feb 5 '15 at 10:41
  • Thanks it helps in fact, it means that it's possibly my machine, but Ubuntu is not slow by the way... so that's why I thought it could come from Firefox default configuration... If nobody has the same problem, it may means that it comes from me :) – tasseb Feb 5 '15 at 10:50
3

What is slow? Switching between tabs, opening a site, scrolling the window...? It might be your graphic drivers. If you have an nVidia card try installing the non-free nVidia drivers rather than the stock ones that come with Ubuntu.

UPDATE:
Okay, if it's the network access that is slow my guess would be that you have IPv6 enabled. Try running sudo apt-get update from a terminal window, and if you get the same 5-10 second pause then try disabling IPv6. The "quick" way to do that (just for testing) would be to edit /etc/gai.conf and add the following line to it:

precedence ::ffff:0:0/96  100

Restart firefox and see if that speeds things up. If it does, a better way to disable IPv6 is described in this answer to the question How to disable IPv6 in Ubuntu 14.04?

  • Loading a web page is slow, opening a new tab is really fast. My Internet connection is quite ok, loading web page on other system is normal... I'll get a look on my graphic drivers thanks – tasseb Feb 5 '15 at 11:21
  • @Charles thanks, I've run the update, then I've uncommented the line "precedence..." on /etc/gai.conf, and after restarting Firefox it's much better! thanks a lot – tasseb Feb 6 '15 at 11:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.