0

I want to clear the snapshots of Cassandra using :

nodetool -h localhost -p 7199 clearsnapshot

but it gives me an exception :

Exception in thread "main" FSWriteError in /var/lib/cassandra/data/system   /compactions_in_progress/snapshots/1423043461812-compactions_in_progress/system-compactions_in_progress-jb-2097-Statistics.db

to solve this issue i ran this command :

sudo  sysctl -w kernel.yama.protected_nonaccess_hardlinks=0

but it gives me kernel.yama.protected_nonaccess_hardlinks is an unknown key

so what is the problem and how can i solve it ?

  • in my case it resolved by rebooting – Mostafa Jamareh Feb 5 '15 at 7:00
0

While you already solved your issue by rebooting, I'm posting in hopes that someone else will benefit. I know I would have.

It seems that the sysctl was changed somewhere between the kernels used in Ubuntu 12.04 and 14.04. The new sysctl key is fs.protected_hardlinks. There is also a config for this (and the similar key fs.protected_symlinks) in /etc/sysctl.d/10-link-restrictions.conf that will enable this by default at boot, so be sure to edit this file as well.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.