1

I am using 14.04, I recently did an update with the software updater and things went wrong. Not sure what however, I just kept running it until it said that things were up to date.

Now things are very weird. Now it seems that most things I run from the GUI works fine, I can surf the web (and post to askubuntu) I can play music, watch videos.. etc. although the software center is crashing. And the software updater it nowhere to be found now.

I have rebooted several times.

But almost anything I do from the terminal fails, and the terminal closes. Things I can't do from the terminal:

  1. I can cd to /etc, but when I ls, the terminal closes. (ls does work in most directories, but not all, and I can't tell why)

  2. I can't run maven. (I run mvn clean) and terminal closes

  3. I can't run java (but java -version works) so weird.

  4. apt-get update crashes

and a bunch of other things.

I assume I am looking at a re-install here. Can I just do an upgrade of Ubuntu, WITHOUT having to re-install. I do have all my work on a separate partition (/opt) so I would like to not touch that.

Any pointers?

UPDATE:

I am getting this error in Muon Update Manager:

Couldn't create temporary file to work with /var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_trusty_Release - 
mkstemp (13: Permission denied)

I am also noticing that I cannot download attachments and stuff from FF.

It almost seems like I am not logged in as who I think I am. Why would I not have permission for FF to write to my own Download folder?

closed as off-topic by Anwar, Zanna, Eric Carvalho, muru, karel Apr 8 '17 at 12:45

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This describes a problem that can't be reproduced that seemingly went away on its own or was only relevant to a very specific period of time. It's off-topic as it's unlikely to help future readers." – Anwar, Zanna, Eric Carvalho, muru, karel
If this question can be reworded to fit the rules in the help center, please edit the question.

  • What went wrong with the software-updater(can you recall)? Also any error message while doing ls /etc? – heemayl Feb 5 '15 at 4:47
  • I don't recall. It just said it stopped functioning. And there are no errors, the terminal just closes. – mmaceachran Feb 5 '15 at 4:52
  • Open tail -f /var/log/syslog in a terminal and do ls /etc from a separate terminal, now as the second terminal closes check the syslog and add the relevant entries to your original question. – heemayl Feb 5 '15 at 4:53
  • I can tail -f, but when I open a new terminal and run ls /etc both terminals close. I open a new terminal, and tail -f, and nothing new is in the syslog – mmaceachran Feb 5 '15 at 4:58
  • 1
    OP reinstalled the latest OS and leaves a note to the kids in the answer section, I'm voting to close the question – Anwar Apr 7 '17 at 11:25
0

I upgraded to 14.10 and that fixed it.

Remember kids: it's always a good idea to partition your HDD and keep your stuff off the root partition. That way, when you reinstall, you just re-mount your partition, and everything was like it was. (except for apps, users, etc..) But at least I still have my data!

  • 1
    For the future: Please read: What's a good back-up strategy for 1 desktop PC? That way, you just restore your system back-up to a previous state (You're definitely user type 4), apply updates, done! No need to install your applications again! – Fabby Feb 9 '15 at 15:30

Not the answer you're looking for? Browse other questions tagged or ask your own question.