0

This new laptop I have has a weird issue with sound effects: occasionally, I presume due to some low-moderate level of load, the audio subsystem gets stuck, delaying sound effects (and sometimes temporarily freezing my screen in the process) for a few seconds. I imagine this is happening specifically to libcanberra sound effects, such as when I hit tab in gnome-terminal without any completion. (Konversation's sound effects also play with a delay, but not a hard-freezing one, and I've always observed that weirdness, even when using KDE on my old laptop...) After this first delay, the sound effect will work fine for a while, then go back to working as described above after not having a sound effect for a while.

Worse, however, is using the volume control buttons on my keyboard. The first time, the sound effect will play just fine (with no delay). The second time, the sound effect doesn't play at all. Or sometimes, it will wait a few seconds, then start playing the volume change sound effect repeatedly, up to 16 times in a row, even if I hold the volume change buttons down. Temporary freezing might happen; I'm not too sure... (Using the volume control slider in a GUI controller only has the delay for the sound effect.)

Programs that actually play audio (like mpv, fceux, firefox, etc.) work fine with no issues. This specifically affects sound effects, or so it seems.

I have tried pulseaudio -k. I have tried sudo alsa force-reload. It seems the kernel module snd_hda_intel refuses to be unloaded due to being in use, but whatever it was I tried to find out what was using it (I can't find it anymore :argh: ) reports nothing is using it. Everything works fine again after a reboot until the next time whatever the cause is happens again.

Is there anything I can do to fix this?

Ubuntu GNOME 14.10 fglrx-updates 2:14.201-0ubuntu2 installed via Additional Drivers Lenovo G50-45 AMD A6-6310 APU with AMD Radeon R4 Graphics I'm... not exactly sure what the audio device is; every command-line tool tells me something different, and gnome-control-center's Sound panel only says "Speakers - Built-in Audio".

Thanks.

0

Upgrading to Vivid seems to fix the issue for me. Oh well :/ Thanks anyway!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.