0

I've been trying to upgrade two servers from 12.04 LTS to 14.04 LTS for a few days now using do-release-upgrade. It seems that they're both getting hung up on downloading the last of two updates.

For one, I can't fetch vim-runtime from trusty/main and linux-headers-3.13.0-45 from trusty-updates/main. For the other, I again can't fetch vim-runtime from and libicu-dev.

In all cases, I get some variation of

Err http://xx.archive.ubuntu.com/ubuntu/ <blah blah> Connection failed [IP: nnn.nn.nn.nn 80]

where the country prefix, package, and IP address are different depending on the download that's failing.

I've tried changing /etc/apt/sources.list to various mirrors (Canada, US, Germany, and without a country prefix) and running sudo apt-get update && sudo apt-get upgrade after each change to the sources list.

I've even tried adding Amazon's EC2 mirros per this question and I still get the same connection failures.

I can ping the IP addresses. I can even wget the .deb packages directly from the failed-to-fetch links provided when do-release-upgrade aborts.

Both servers are running as virtual machines under Hyper-V on the same Windows server. All other updates downloaded (eventually).

Any thoughts on how I can move past this issue and upgrade these servers?

1 Answer 1

2

While I was never able to resolve the issue of why the downloads for these packages would not complete, I was finally able to complete the upgrade as follows:

  1. cd /var/cache/apt/archives
  2. wget package_name.deb
  3. Repeat step 2 for all missing packages.
  4. do-release-upgrade

Hope this helps anyone else that might be having difficulty with this.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.