9

I have a a multi card reader. Today accidentally I ejected my reader while formatting a SD card by Gparted. When I inserted it again, it detected is lsusb but nothing was opening ie. as a storage device.

I tried inserting SD card in laptop SD card reader and it worked fine. But with the card reader I was unable to see anything. I tried googling with several links and suggestion which says kernel compiling and all but nothing helped. I tried to open it via Gparted but it kept on searching partitions and after a long time it showed my internal hard disk only

This is lsusb result

Bus 001 Device 009: ID 05e3:0751 Genesys Logic, Inc.

This is lsusb -v result for that device

Bus 001 Device 010: ID 05e3:0751 Genesys Logic, Inc. 
Couldn't open device, some information will be missing
Device Descriptor:
  bLength                18
  bDescriptorType         1
  bcdUSB               2.00
  bDeviceClass            0 (Defined at Interface level)
  bDeviceSubClass         0 
  bDeviceProtocol         0 
  bMaxPacketSize0        64
  idVendor           0x05e3 Genesys Logic, Inc.
  idProduct          0x0751 
  bcdDevice           14.01
  iManufacturer           3 
  iProduct                4 
  iSerial                 0 
  bNumConfigurations      1
  Configuration Descriptor:
    bLength                 9
    bDescriptorType         2
    wTotalLength           32
    bNumInterfaces          1
    bConfigurationValue     1
    iConfiguration          0 
    bmAttributes         0x80
      (Bus Powered)
    MaxPower               98mA
    Interface Descriptor:
      bLength                 9
      bDescriptorType         4
      bInterfaceNumber        0
      bAlternateSetting       0
      bNumEndpoints           2
      bInterfaceClass         8 Mass Storage
      bInterfaceSubClass      6 SCSI
      bInterfaceProtocol     80 Bulk-Only
      iInterface              0 
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x81  EP 1 IN
        bmAttributes            2
          Transfer Type            Bulk
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0200  1x 512 bytes
        bInterval               0
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x02  EP 2 OUT
        bmAttributes            2
          Transfer Type            Bulk
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0200  1x 512 bytes
        bInterval               0

This is sudo fdisk -l result

Disk /dev/sda: 1000.2 GB, 1000204886016 bytes
255 heads, 63 sectors/track, 121601 cylinders, total 1953525168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disk identifier: 0x72c8ec7f

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *        2048      718847      358400    7  HPFS/NTFS/exFAT
/dev/sda2          718848   210434047   104857600    7  HPFS/NTFS/exFAT
/dev/sda3       210434048   944437247   367001600    7  HPFS/NTFS/exFAT
/dev/sda4       944439294  1953523711   504542209    5  Extended
Partition 4 does not start on physical sector boundary.
/dev/sda5       944439296   960438271     7999488   82  Linux swap / Solaris
/dev/sda6       960440320  1953523711   496541696   83  Linux

This is sudo sg_scan -i result

/dev/sg0: scsi0 channel=0 id=0 lun=0 [em]
    ATA       HGST HTS721010A9  JB0O [rmb=0 cmdq=0 pqual=0 pdev=0x0] 
/dev/sg1: scsi1 channel=0 id=0 lun=0 [em]
    Optiarc   DVD RW AD-7560A   DH10 [rmb=1 cmdq=0 pqual=0 pdev=0x5] 
/dev/sg2: scsi9 channel=0 id=0 lun=0 [em]
    Generic   STORAGE DEVICE    1401 [rmb=1 cmdq=0 pqual=0 pdev=0x0] 

This is sudo sg_map result

/dev/sg0  /dev/sda
/dev/sg1  /dev/sr0
/dev/sg2  /dev/sdb

Is there any remedy available to make that card reader work?

  • 2
    I am afraid that you might have corrupted the SD card and you probably have to reformat it again. – Alex Lowe Dec 15 '15 at 20:05
  • Please plug in your card reader and the storage card, wait 10–30 seconds and run lsblk and sudo dmesg | tail -n 20. Include the output in your question. This will hopefully tell us more about what the kernel is doing with the storage medium in the background. – David Foerster Dec 17 '15 at 11:09
  • I have a laptop with an SD card reader and, with that I can create, read and write to cards just fine. However, I plug the same card into my ubuntu box with a reader an I get the above results. My dmesg shows the device was detected, module loaded, but /dev/sdb was not available. lsusb shows as above. I've examined the card reader under a microscope and the circuit board is fine. It suggests a firmware issue, but I'm baffled as to how to progress. – sibaz Dec 18 '15 at 13:17
  • @sibaz: Please open a new question for your issue, unless it's the same card reader and memory card. Provide the same information as in this question plus what people requested in the comments. Give me a ping and I'll have a look at it. – David Foerster Dec 18 '15 at 13:37
  • Done: askubuntu.com/questions/710899/… – sibaz Dec 18 '15 at 14:04
1

Use the following steps:

  1. Remove the multi-card card reader from your machine
  2. Cold boot your machine. (shutdown, remove all batteries and power, turn on (which should do nothing, except get rid of the last few electrons) then connect all batteries and power cords and turn on again)
  3. Insert the SD card in your internal SD Card reader, open gparted and re-create a new partition table and re-format the SD Card.
  4. Unmount and eject the SD Card from your internal SD card reader
  5. Insert the SD card in the (still removed!!!) Multi-card reader.
  6. Connect the multi-card reader again.

Done!

| improve this answer | |
  • 1
    Problem is with Multicard reader. Not SD card. Multicard reader firmware messed up. And I didn't find that particular firmware. hence I had to leave it as it is. If SD card was not fine then it wouldn't open with internal card reader and another multi card reader as well :) – ninja.stop Feb 10 '15 at 5:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.