17

There is an error sign on my Ubuntu panel which states the error given in the title. I used sudo apt-get update but it gave me no errors. However the error sign persists.

How do I fix this?

18

I got the same error in 14.04. Re-installation of wine-staging-i386 package fixed the problem:

sudo apt-get install --reinstall wine-staging-i386
6
  • I have the same problem but it the error keeps coming back every once in while I update Ubuntu even after trying the above. – XiaoChuan Yu Jun 22 '15 at 2:39
  • 1
    I couldn't find a better solution. Looks like its a known bug. I run the fix every time after upgrade.askubuntu.com/questions/594888/… For more information check the bug report. bugs.launchpad.net/pipelight/+bug/1318321 – 7H3ju Jun 23 '15 at 13:13
  • works for me, I got error notification for lib6c-amd64 using --reinstall solve the problem – Gujarat Santana Oct 26 '16 at 14:04
  • E: Unable to locate package wine-staging-i386 – Alendorff Jul 11 '17 at 6:49
  • I think the package may be different for everyone. For me, I had to run: sudo apt-get install --reinstall wine1.6-i386 which was the package that was giving me the error. Maybe the same command will work for you? @Alendorff – Lewis Menelaws Jul 13 '17 at 0:49
1

If you're running Ubuntu 64 bit then the problem is likely due to the fact that "wine-staging-amd64" depends on "wine-staging-i386" which is a virtual package and not actually installable. From what I can deduce from reading about this here "the cache has no package" error when wine update is available is that the build environment or updater isn't dealing with the multiarch nature of this "wine" install.

If you're not using the pipelight experimental 64bit flash or unity3d plugins and don't require the 64bit version of "wine-staging" for anything else, then you could always remove "wine-staging-amd64" and it's dependencies. If this is what you want to do then make sure to disable any 64 bit plugins you have enabled/loaded in pipelight first as follows:

pipelight-plugin --disable x64-flash

and/or

pipelight-plugin --disable x64-unity3d

Note: You may need to use "sudo" at the start of those if you installed the 64 bit plugins for all users.

Then proceed with uninstalling the 64 bit version of "wine-staging" as follows:

sudo aptitude -V purge wine-staging wine-staging-amd64 wine-staging:i386+

This will uninstall "wine-staging" (64 bit) dependancy package and "wine-staging-amd64" (64 bit) and install "wine-staging:i386" (32 bit) dependancy package.

The 32 bit package depends on only 32 bit so don't have a problem as far as I can tell so far.

Note: YMMV ;)

0

I also keep getting the Unknown error: '<class 'KeyError'>' (“The cache has no package named wine-staging-i386”)

I have tried other solutions including those shown here: How can I resolve repeated package dependency error involving ' wine-staging-i386 '. They suggested doing a sudo apt-get update as well as the same solution listed above sudo apt-get install --reinstall wine-staging-i386.

The one that works for me to remove the annoying warning is to use Y-PPA Manager and under 'Advanced' click on 'Try to import all missing GPG keys'. Once I do this, the warning goes away. I have to do this every time the warning shows up. It's annoying and not a real "fix" but again it works when other better fixes don't seem to help.

0

There seem to be several options to resolve this problem.

But first, some education. The error is to alert the user (obviously) that there is a mismatch in downloaded dependencies (depending on your system) for i386 or x86.

for 15.04 and later: sudo apt-get upgrade seems to be the key to fixing the problem.

for 14.04 and earlier: sudo apt-get update wine-staging-i386 has been reported to work.

Additionally, as Exomancer stated,

The one that works for me to remove the annoying warning is to use Y-PPA Manager and under 'Advanced' click on 'Try to import all missing GPG keys'. Once I do this, the warning goes away. I have to do this every time the warning shows up. It's annoying and not a real "fix" but again it works when other better fixes don't seem to help.

also see question: How can I resolve repeated package dependency error involving ' wine-staging-i386 '

1
  • apt-get upgrade did the trick in Ubuntu 16.04. Thanks Jaxor! – Michael Zukowski Jul 11 '17 at 6:45
0

I could not solve this by reinstalling or upgrading.

For Ubuntu 16.04 LTS or later, you can simply run

sudo apt-get install wine1.6

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.