27

When the Gnome desktop has focus, hitting F1 brings up "Ubuntu Desktop Guide". How do I disable this keyboard shortcut?

UPDATE: This problem seems to be gone in Ubuntu 12.04 (hitting F1 while the desktop has focus does nothing). I believe the question is specific to Ubuntu 10.04 which I no longer have installed, so I cannot verify the answers.

I will accept whatever answer is confirmed by the community (post a comment on the answer that works for you) and please mention what Ubuntu version you're using.

2
  • The problem is back in Ubuntu 18.04. The answers below no longer work.
    – brandones
    Nov 18, 2018 at 19:10
  • If you are like me and hate help browser popping up when you want to hit Esc or F2, but accidentally hit F1 instead, you can remove the yelp package, which contains the pesky gnome-help browser. After that F1 will do mostly nothing, not even changing the input focus. Works on 18.04 and 20.04. Jun 8, 2020 at 19:22

7 Answers 7

19

For 12.10

You can disable the help browser by opening "System Settings" -> "Keyboard" and switching to the "Shortcuts" tab, then under "Launchers" turning "Launch Help Browser" to "Disabled".

enter image description here

However some applications, for example the terminal, have their own help settings you will have to turn off as well. For the terminal, open the "Edit" menu and click on "Keyboard Shortcuts". Scroll to the bottom and change the key for "Contents" under "Help". To turn the shortcut off, select it and then hit backspace.

enter image description here

5
  • 1
    Please specify Ubuntu version numbers as this does not seem to exist in 12.04.
    – Gili
    Jan 19, 2013 at 20:59
  • @Gili I did this in 12.10 though I think it should be there in 12.04 also.
    – Seth
    Jan 20, 2013 at 4:18
  • It works for gnome-terminal in Ubuntu 13.10. Thanks. Dec 19, 2013 at 7:31
  • This works for Ubuntu 14.04 LTS
    – RoraΖ
    Aug 26, 2015 at 12:20
  • Using Backspace in this case is so intuitive... Thanks! Jun 22, 2016 at 13:10
5

14.04

Install the DConf editor, go to org > gnome > desktop > wm > keybindings.

Assign the F1 key to some inoffensive function, like 'raise'.

3
  • 2
    Checked and works in 14.04. Is more like a workaround than a real solution, but at least now the annoying gnome help app don't appears every time I miss the Esc key when working with vim :P
    – sucotronic
    Jul 21, 2014 at 11:10
  • Is this dconf - Simple tool for manipulating a dconf database? If not, what package name?
    – Tom Hale
    Sep 25, 2016 at 7:06
  • No, it's a simple tool for storing desktop environment settings. Get it with sudo apt-get install dconf-editor
    – Pertinax
    Aug 19, 2017 at 12:59
2

You can go into Settings->Keyboard->Shortcuts->Starter and press backspace on the coressponding item. Sth. like 'Launch help'

However other applications might still open their help on F1

3
  • There is no "Starter" entry under Ubuntu 12.04.
    – Gili
    Jan 17, 2013 at 20:00
  • Anything similar to that maybe? It was a loose translation from German
    – JavaJens
    Jan 17, 2013 at 23:07
  • 1
    The key point that @JavaJens makes here is that some applications hook the F1 key to the application's Help file. Disabling F1 at the OS level will not always disable it at the application level.
    – Ed Manet
    Jan 18, 2013 at 20:49
2

In Ubuntu 20.04

gsettings set org.gnome.settings-daemon.plugins.media-keys help '[]' 

it works in my laptop

2
  • Doesn't work for me May 20, 2021 at 9:35
  • 1
    worked for me on 20.04 Oct 25, 2021 at 16:43
0

Just to Disable F1 may not be functioning in gnome. The practice way to avoid F1 to bring up Help window is to assign it to some unused function or a common function, such as 'raise'.

In most Ubuntu releases, using Settings->Keyboard->Shortcuts to assign F1 to 'raise' should work, except Ubuntu 14.04. Under Ubuntu 14.04, use dconf-editor to reassign F1 to 'raise' described by The Thunder Chimp above.

0

For Linux Mint 20.10

I'm running gnome. I just opened settings, didn't see anything for F1 so I added one and named it F1, for command just added null and then typed the F1 key. This seems to have worked to disable F1 default behavior for example in my browser.

0

Yeah, I thought it was basically hard-wired into the system, as I've never found where that was set, but turns out I could just reassign F1 to something else by making a custom keyboard shortcut. Who woulda thunk it?! So I figured rather than let a good key go to waste, I assigned it to open the Pictures folder. Note if you want to do something like that, you can't use a tilde (~) in the path, but have to use the full path, or it will fail.

I did this in Ubuntu 20.04, in the MATE desktop. Haven't checked if this is set in Gnome and KDE as well (since I'm doing it in MATE's Keyboard Shortcuts), but looks like I'd be able to do this in those DEs too, if needed.

Many thanks to you guys for your replies in this thread!

F1 to open Pictures folder

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.